aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mohawk/Makefile38
-rw-r--r--www/mohawk/distinfo2
-rw-r--r--www/mohawk/files/mohawk.in28
-rw-r--r--www/mohawk/pkg-descr11
5 files changed, 80 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 338ba128bfdc..33221b0ad3ff 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -574,6 +574,7 @@
SUBDIR += mod_xml2enc
SUBDIR += mod_xmlns
SUBDIR += mod_xsendfile
+ SUBDIR += mohawk
SUBDIR += moinmoin
SUBDIR += momspider
SUBDIR += monast
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
new file mode 100644
index 000000000000..1dc0e973546c
--- /dev/null
+++ b/www/mohawk/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mohawk
+# Date created: 2011-04-15
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mohawk
+PORTVERSION= 0.8
+CATEGORIES= www ipv6
+MASTER_SITES= http://files.etoilebsd.net/mohawk/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Simple and lightweight HTTP daemon
+
+LICENSE= BSD
+
+MAN1= mhtpasswd.1
+MAN8= mohawk.8
+
+PLIST_FILES+= bin/mhtpasswd \
+ sbin/mohawk \
+ etc/mohawk.conf.sample
+
+USE_RC_SUBR= mohawk
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800000
+BROKEN= does not build on RELENG_7
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/.*rc.d\/mohawk.*/d' ${WRKSRC}/Makefile
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/mohawk.conf ${PREFIX}/etc/mohawk.conf.sample
+
+.include <bsd.port.post.mk>
diff --git a/www/mohawk/distinfo b/www/mohawk/distinfo
new file mode 100644
index 000000000000..36b965cdfcfa
--- /dev/null
+++ b/www/mohawk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mohawk-0.8.tar.gz) = b6f39c9ffa560d65b5bf79bcb9fe7933491abd3090e7159afbcde05b32e3f22b
+SIZE (mohawk-0.8.tar.gz) = 26264
diff --git a/www/mohawk/files/mohawk.in b/www/mohawk/files/mohawk.in
new file mode 100644
index 000000000000..01ce79c2e958
--- /dev/null
+++ b/www/mohawk/files/mohawk.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# PROVIDE: mohawk
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable mohawk:
+#
+# mohawk_enable (bool): Set it to "YES" to enable mohawk
+# Default is "NO".
+# mohawk_conf (path): Set full path to config file.
+# Default is "%%PREFIX%%/etc/mohawk.conf".
+
+. /etc/rc.subr
+
+name="mohawk"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${mohawk_enable="NO"}
+: ${mohawk_conf="%%PREFIX%%/etc/mohawk.conf"}
+
+command=%%PREFIX%%/sbin/mohawk
+command_args="-c ${mohawk_conf}"
+required_files=${mohawk_conf}
+
+run_rc_command "$1"
diff --git a/www/mohawk/pkg-descr b/www/mohawk/pkg-descr
new file mode 100644
index 000000000000..b7735e0a43f4
--- /dev/null
+++ b/www/mohawk/pkg-descr
@@ -0,0 +1,11 @@
+Simple and lightweight HTTP daemon.
+
+It provides the following features:
+- Basic support for CGI,
+- ipv6, authentication,
+- virtual host,
+- basic authentication
+- basic url mapping system.
+
+
+WWW: http://git.etoilebsd.net/mohawk