aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/mohawk/Makefile23
-rw-r--r--www/mohawk/distinfo4
-rw-r--r--www/mohawk/files/patch-man5__Makefile7
-rw-r--r--www/mohawk/files/patch-man8__Makefile7
-rw-r--r--www/mohawk/pkg-descr2
5 files changed, 31 insertions, 12 deletions
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
index 680cee003631..e5150dd5c2b1 100644
--- a/www/mohawk/Makefile
+++ b/www/mohawk/Makefile
@@ -6,22 +6,21 @@
#
PORTNAME= mohawk
-PORTVERSION= 0.9
+PORTVERSION= 2.0
CATEGORIES= www ipv6
-MASTER_SITES= http://files.etoilebsd.net/mohawk/
+MASTER_SITES= http://files.etoilebsd.net/mohawk/ \
+ http://mohawk.bsdsx.fr/
-MAINTAINER= bapt@FreeBSD.org
+MAINTAINER= mohawk@bsdsx.fr
COMMENT= Simple and lightweight HTTP daemon
LICENSE= BSD
-MAN1= mhtpasswd.1
-MAN8= mohawk.8
-
PLIST_FILES+= bin/mhtpasswd \
sbin/mohawk \
etc/mohawk.conf.sample
+PORTEXAMPLES= *
USE_RC_SUBR= mohawk
.include <bsd.port.pre.mk>
@@ -29,10 +28,16 @@ USE_RC_SUBR= mohawk
BROKEN= does not build
.endif
-post-patch:
- @${REINPLACE_CMD} -e '/.*rc.d\/mohawk.*/d' ${WRKSRC}/Makefile
+LIB_DEPENDS= event-2.0:${PORTSDIR}/devel/libevent2
+CFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib/event2
post-install:
- @${INSTALL_DATA} ${WRKSRC}/mohawk.conf ${PREFIX}/etc/mohawk.conf.sample
+ @${INSTALL_DATA} ${WRKSRC}/examples/minimal.conf ${PREFIX}/etc/mohawk.conf.sample
+ @${INSTALL_SCRIPT} ${WRKSRC}/mhtpasswd.sh ${PREFIX}/bin/mhtpasswd
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/*.conf ${EXAMPLESDIR}
+.endif
.include <bsd.port.post.mk>
diff --git a/www/mohawk/distinfo b/www/mohawk/distinfo
index 47fc9520b0c9..2c41ed6beb4a 100644
--- a/www/mohawk/distinfo
+++ b/www/mohawk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mohawk-0.9.tar.gz) = 9c79b82cb3760462f8c5f6edfbbb68c67650692ae25248294dc9974e39be5ede
-SIZE (mohawk-0.9.tar.gz) = 26556
+SHA256 (mohawk-2.0.tar.gz) = 6cef4ff7a18a61a807b7f5ba9819f76fefc9ff49f41dfeb0fee75db7d1044b23
+SIZE (mohawk-2.0.tar.gz) = 45363
diff --git a/www/mohawk/files/patch-man5__Makefile b/www/mohawk/files/patch-man5__Makefile
new file mode 100644
index 000000000000..0da51ff81de4
--- /dev/null
+++ b/www/mohawk/files/patch-man5__Makefile
@@ -0,0 +1,7 @@
+--- ./man5/Makefile.orig 2012-05-28 13:26:48.000000000 +0200
++++ ./man5/Makefile 2012-05-28 13:27:02.000000000 +0200
+@@ -1,3 +1,4 @@
++SHAREDIR= ${PREFIX}
+ MAN= mohawk.conf.5
+
+ .include <bsd.prog.mk>
diff --git a/www/mohawk/files/patch-man8__Makefile b/www/mohawk/files/patch-man8__Makefile
new file mode 100644
index 000000000000..e6363babda12
--- /dev/null
+++ b/www/mohawk/files/patch-man8__Makefile
@@ -0,0 +1,7 @@
+--- ./man8/Makefile.orig 2012-05-28 13:27:10.000000000 +0200
++++ ./man8/Makefile 2012-05-28 13:27:22.000000000 +0200
+@@ -1,3 +1,4 @@
++SHAREDIR= ${PREFIX}
+ MAN8= mhtpasswd.8 mohawk.8
+
+ .include <bsd.prog.mk>
diff --git a/www/mohawk/pkg-descr b/www/mohawk/pkg-descr
index 1950c6a087a1..e27377896a8a 100644
--- a/www/mohawk/pkg-descr
+++ b/www/mohawk/pkg-descr
@@ -7,4 +7,4 @@ It provides the following features:
- basic authentication
- basic url mapping system.
-WWW: http://git.etoilebsd.net/mohawk
+WWW: http://fossil.etoilebsd.net/mohawk