aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/vte3/Makefile')
-rw-r--r--x11-toolkits/vte3/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index cf242aa0e4a4..a057dcb4915f 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vte
-PORTVERSION= 0.42.4
-PORTREVISION= 2
+PORTVERSION= 0.48.1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 3
@@ -12,19 +11,21 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Terminal widget with improved accessibility and I18N support
+LICENSE= LGPL21
+
BUILD_DEPENDS+= vapigen:lang/vala \
- bash:shells/bash
-LIB_DEPENDS= libgnutls.so:security/gnutls
+ bash:shells/bash \
+ gperf:devel/gperf
+LIB_DEPENDS= libgnutls.so:security/gnutls \
+ libpcre2-8.so:devel/pcre2
PORTSCOUT= limitw:1,even
-USES= bison compiler:c++0x gettext gmake gnome libtool pathfix \
- pkgconfig tar:xz
+USES= bison compiler:c++0x gettext gmake gnome libtool localbase \
+ pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gtk30 intltool referencehack introspection:build
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-introspection \
--disable-static \
--disable-Bsymbolic