aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/vte3/Makefile')
-rw-r--r--x11-toolkits/vte3/Makefile32
1 files changed, 15 insertions, 17 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index b81d9da35c2a..655f50e10206 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -1,10 +1,10 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11-toolkits/vte3/Makefile 18941 2013-12-08 01:18:10Z kwm $
+# $MCom: ports/trunk/x11-toolkits/vte3/Makefile 19957 2014-10-15 11:07:14Z gusi $
PORTNAME?= vte
-PORTVERSION= 0.34.7
-PORTREVISION?= 1
+PORTVERSION= 0.38.0
+PORTREVISION?= 0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/gnome-pty-helper/vte/}/${PORTVERSION:R}
@@ -12,15 +12,17 @@ DISTNAME= vte-${PORTVERSION}
PKGNAMESUFFIX?= 3
DIST_SUBDIR= gnome3
-MAINTAINER?= gnome@FreeBSD.org
-COMMENT?= Gtk 3 based terminal widget with accessibility and I18N support
+MAINTAINER= gnome@FreeBSD.org
+COMMENT?= Terminal widget with improved accessibility and I18N support
-USES+= tar:xz
+USES= tar:xz
.if !defined(REFERENCE_PORT)
VTE3_SLAVE?= no
-.if ${VTE3_SLAVE}!="yes"
+.if ${VTE3_SLAVE} != yes
+BUILD_DEPENDS+= vapigen:${PORTSDIR}/lang/vala \
+ bash:${PORTSDIR}/shells/bash
RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
.endif
@@ -29,7 +31,7 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gnomeprefix gtk30 referencehack introspection:build
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS?=--disable-python \
--with-gtk=3.0 \
--enable-introspection \
@@ -39,12 +41,7 @@ CONFIGURE_ARGS?=--disable-python \
--disable-freetypetest
INSTALL_TARGET= install-strip
-.if !defined(MASTERDIR)
-OPTIONS_DEFINE= GLX
-GLX_DESC= Support for DRI/GLX rendering
-.endif
-
-PLIST_SUB= VERSION=2.90
+PLIST_SUB= VERSION=2.91
.include <bsd.port.options.mk>
@@ -52,9 +49,10 @@ PLIST_SUB= VERSION=2.90
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-pty-helper_gnome-utmp.c
.endif
-.if ${PORT_OPTIONS:MGLX} && !defined(MASTERDIR)
-CONFIGURE_ARGS+= --with-glX
-USE_GL= yes
+.if ${VTE3_SLAVE} != yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
+ ${WRKSRC}/src/Makefile.in
.endif
.include <bsd.port.mk>