aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/vte3/Makefile')
-rw-r--r--x11-toolkits/vte3/Makefile45
1 files changed, 11 insertions, 34 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index 96e1eddcaa09..4160d9bb2355 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -1,47 +1,32 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-PORTNAME?= vte
-PORTVERSION= 0.40.2
-PORTREVISION?= 0
+PORTNAME= vte
+PORTVERSION= 0.42.3
CATEGORIES= x11-toolkits gnome
-MASTER_SITES= GNOME/sources/${PORTNAME:S/gnome-pty-helper/vte/}/${PORTVERSION:R}
-DISTNAME= vte-${PORTVERSION}
-PKGNAMESUFFIX?= 3
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 3
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT?= Terminal widget with improved accessibility and I18N support
+COMMENT= Terminal widget with improved accessibility and I18N support
-USES= tar:xz
-
-.if !defined(REFERENCE_PORT)
-VTE3_SLAVE?= no
-PORTSCOUT= limitw:1,even
-
-.if ${VTE3_SLAVE} != yes
BUILD_DEPENDS+= vapigen:${PORTSDIR}/lang/vala \
bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
-.else
-# we need gnutls for configure to pass for gnome-pty-helper ..
-BUILD_DEPENDS+= gnutls>=0:${PORTSDIR}/security/gnutls
-.endif
-USES+= bison gettext gmake libtool pathfix pkgconfig
+PORTSCOUT= limitw:1,even
+
+USES= bison compiler:c++0x gettext gmake gnome libtool pathfix \
+ pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gtk30 intltool referencehack introspection:build
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS?=--disable-python \
- --with-gtk=3.0 \
- --enable-introspection \
+CONFIGURE_ARGS= --enable-introspection \
--disable-static \
- --disable-Bsymbolic \
- --disable-gnome-pty-helper \
- --disable-freetypetest
+ --disable-Bsymbolic
INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=2.91
@@ -53,10 +38,8 @@ LIBS+= -lz
.endif
post-patch:
-.if ${VTE3_SLAVE} != yes
@${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
${WRKSRC}/src/Makefile.in
-.endif
# zlib.pc only is available on 10.1-R and newer.
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 || ${OPSYS} == DragonFly
@${REINPLACE_CMD} -e 's|gio-unix-2.0 zlib|gio-unix-2.0|g' \
@@ -68,11 +51,5 @@ post-patch:
s|-fstack-protector||g' \
${WRKSRC}/configure
.endif
- @${REINPLACE_CMD} -e 's|(AM_MAKEFLAGS) install-exec-hook|(AM_MAKEFLAGS)|g' \
- ${WRKSRC}/gnome-pty-helper/Makefile.in
.include <bsd.port.mk>
-
-.else
-PORTSCOUT= ignore:1
-.endif