aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wlroots
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/wlroots')
-rw-r--r--x11-toolkits/wlroots/files/patch-include_wlr_types_wlr__seat.h26
-rw-r--r--x11-toolkits/wlroots/pkg-message2
2 files changed, 0 insertions, 28 deletions
diff --git a/x11-toolkits/wlroots/files/patch-include_wlr_types_wlr__seat.h b/x11-toolkits/wlroots/files/patch-include_wlr_types_wlr__seat.h
deleted file mode 100644
index 29f8e9ea55fa..000000000000
--- a/x11-toolkits/wlroots/files/patch-include_wlr_types_wlr__seat.h
+++ /dev/null
@@ -1,26 +0,0 @@
-https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231425
-
-In file included from ../sway/ipc-json.c:7:
-In file included from ../include/sway/ipc-json.h:5:
-In file included from ../include/sway/input/input-manager.h:6:
-In file included from ../include/sway/server.h:9:
-In file included from /usr/local/include/wlr/types/wlr_data_device.h:13:
-/usr/local/include/wlr/types/wlr_seat.h:197:18: error: field has incomplete type 'struct timespec'
- struct timespec last_event;
- ^
-/usr/local/include/wlr/types/wlr_output.h:123:9: note: forward declaration of 'struct timespec'
- struct timespec *when;
- ^
-
---- include/wlr/types/wlr_seat.h.orig 2019-08-01 16:00:48 UTC
-+++ include/wlr/types/wlr_seat.h
-@@ -10,6 +10,9 @@
- #define WLR_TYPES_WLR_SEAT_H
-
- #include <time.h>
-+#if defined(_C11_SOURCE) && defined(__FreeBSD__) && __FreeBSD__ < 12
-+#include <sys/_timespec.h>
-+#endif
- #include <wayland-server-core.h>
- #include <wlr/types/wlr_input_device.h>
- #include <wlr/types/wlr_keyboard.h>
diff --git a/x11-toolkits/wlroots/pkg-message b/x11-toolkits/wlroots/pkg-message
index 02d12355064e..2e15ad5fce88 100644
--- a/x11-toolkits/wlroots/pkg-message
+++ b/x11-toolkits/wlroots/pkg-message
@@ -2,8 +2,6 @@
{ type: install
message: <<EOM
Known issues:
-- On FreeBSD 11.* kernel needs to be rebuilt with EVDEV_SUPPORT
-- On FreeBSD 11.* drm-kmod needs https://github.com/FreeBSDDesktop/kms-drm/pull/213
- NVIDIA may be affected by https://github.com/aritger/eglstreams-kms-example/issues/7
- VULKAN currently requires vulkan-validation-layers
EOM