aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk28/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/wxgtk28/Makefile')
-rw-r--r--x11-toolkits/wxgtk28/Makefile98
1 files changed, 0 insertions, 98 deletions
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
deleted file mode 100644
index f4d663cb8473..000000000000
--- a/x11-toolkits/wxgtk28/Makefile
+++ /dev/null
@@ -1,98 +0,0 @@
-# Created by: fjoe@FreeBSD.org
-
-PORTNAME= wx
-PORTVERSION= 2.8.12
-PORTREVISION?= 10
-CATEGORIES= x11-toolkits
-MASTER_SITES= SF/wxwindows/${PORTVERSION}
-PKGNAMESUFFIX= 28-${WXGTK_FLAVOR}
-DISTNAME= wxGTK-${PORTVERSION}
-
-MAINTAINER?= fjoe@FreeBSD.org
-COMMENT?= The wxWidgets GUI toolkit with GTK+ bindings
-
-LIB_DEPENDS+= libpng.so:graphics/png\
- libtiff.so:graphics/tiff\
- libexpat.so:textproc/expat2
-
-USES= compiler:c++11-lang gl gmake gnome iconv jpeg localbase \
- pkgconfig tar:bzip2 xorg
-USE_CXXSTD= gnu++98
-USE_XORG= x11 sm xxf86vm xinerama
-USE_GL= glu
-USE_GNOME= gtk20 pangox-compat
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libpng=sys\
- --with-libjpeg=sys\
- --with-libtiff=sys\
- --with-zlib=sys\
- --with-expat=sys\
- --with-opengl\
- --with-mspack\
- --with-gtk\
- --disable-mediactrl \
- --disable-backtrace\
- --enable-graphics_ctx
-CONFIGURE_ENV= X11BASE="${LOCALBASE}"
-PLIST= ${.CURDIR}/pkg-plist
-
-WXGTK_FLAVOR?= gtk2
-
-OPTIONS_DEFINE= MSPACK
-OPTIONS_DEFAULT= MSPACK
-MSPACK_DESC= MS archives support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMSPACK}
-CONFIGURE_ARGS+=--with-libmspack
-LIB_DEPENDS+= libmspack.so:archivers/libmspack
-.else
-CONFIGURE_ARGS+=--without-libmspack
-.endif
-
-.if ${WXGTK_FLAVOR} != "gtk2-common"
-RUN_DEPENDS= ${LOCALBASE}/include/wx-2.8/wx/wx.h:x11-toolkits/wxgtk28-common
-.endif
-
-.if ${WXGTK_FLAVOR:M*-common} != ""
-NO_BUILD= yes
-INSTALL_TARGET= install-common
-USES+= gettext-tools
-.else
-USE_LDCONFIG= yes
-.endif # *-common
-
-.if ${WXGTK_FLAVOR:M*-contrib*} != ""
-BUILD_WRKSRC= ${WRKSRC}/contrib
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-.if ${WXGTK_FLAVOR} != "gtk2-contrib-common"
-USE_WX= 2.8
-RUN_DEPENDS= ${LOCALBASE}/include/wx-2.8/wx/stc/stc.h:x11-toolkits/wxgtk28-contrib-common
-
-pre-configure:
- @${FIND} ${BUILD_WRKSRC} -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
- -e "s|@CXXFLAGS@|${CFLAGS} `${WX_CONFIG} --cxxflags`|" \
- -e "s|@CFLAGS@|${CFLAGS} `${WX_CONFIG} --cflags`|" \
- -e "s|@CPPFLAGS@||"
-
-.endif # !gtk2-contrib-common
-.endif # *-contrib*
-
-CONFIGURE_ARGS+=--enable-unicode
-
-.include <bsd.port.pre.mk>
-
-# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
-.if ${COMPILER_TYPE} == gcc
-CONFIGURE_ARGS+= --disable-precomp-headers
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|pkg_config_args --cflags|pkg_config_args pangox --cflags|g ; \
- s|pkg_config_args --libs|pkg_config_args pangox --libs|g' \
- -e 's|png_check_sig|png_sig_cmp|g' \
- ${WRKSRC}/configure
-
-.include <bsd.port.post.mk>