aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/nanogui/Makefile6
-rw-r--r--x11-toolkits/nanogui/files/patch-ext_nanovg_src_nanovg__gl.h11
2 files changed, 14 insertions, 3 deletions
diff --git a/x11-toolkits/nanogui/Makefile b/x11-toolkits/nanogui/Makefile
index 74be91453c40..b184a6e91ca8 100644
--- a/x11-toolkits/nanogui/Makefile
+++ b/x11-toolkits/nanogui/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nanogui
DISTVERSION= g20190922
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits
MAINTAINER= yuri@FreeBSD.org
@@ -23,9 +23,9 @@ USE_XORG= x11 xcursor xi xinerama xrandr xxf86vm
USE_LDCONFIG= yes
CMAKE_OFF= NANOGUI_BUILD_EXAMPLE GLFW_BUILD_EXAMPLES
-OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT= PYTHON
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
PYTHON_CMAKE_BOOL= NANOGUI_BUILD_PYTHON
PYTHON_USES= python
diff --git a/x11-toolkits/nanogui/files/patch-ext_nanovg_src_nanovg__gl.h b/x11-toolkits/nanogui/files/patch-ext_nanovg_src_nanovg__gl.h
new file mode 100644
index 000000000000..de10818d8266
--- /dev/null
+++ b/x11-toolkits/nanogui/files/patch-ext_nanovg_src_nanovg__gl.h
@@ -0,0 +1,11 @@
+--- ext/nanovg/src/nanovg_gl.h.orig 2021-10-16 18:18:49 UTC
++++ ext/nanovg/src/nanovg_gl.h
+@@ -113,7 +113,7 @@ enum NVGimageFlagsGL {
+ #include <stdio.h>
+ #include <string.h>
+ #include <math.h>
+-#include "nanovg.h"
++#include <nanovg.h>
+
+ enum GLNVGuniformLoc {
+ GLNVG_LOC_VIEWSIZE,