aboutsummaryrefslogtreecommitdiff
path: root/x11/foot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/foot/Makefile')
-rw-r--r--x11/foot/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11/foot/Makefile b/x11/foot/Makefile
index cb58fe7e85dd..b4dc7186722c 100644
--- a/x11/foot/Makefile
+++ b/x11/foot/Makefile
@@ -1,17 +1,18 @@
PORTNAME= foot
-DISTVERSION= 1.13.0
+DISTVERSION= 1.17.2
CATEGORIES= x11 wayland
MASTER_SITES= https://codeberg.org/dnkl/${PORTNAME}/archive/${DISTVERSIONFULL}${EXTRACT_SUFX}?dummy=/
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Fast, lightweight and minimalistic Wayland terminal emulator
+WWW= https://codeberg.org/dnkl/foot
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
tllist>=1.0.4:devel/tllist \
- wayland-protocols>0:graphics/wayland-protocols
+ wayland-protocols>=1.32:graphics/wayland-protocols
LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
libwayland-client.so:graphics/wayland \
libfcft.so:x11-fonts/fcft \
@@ -25,8 +26,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= DOCS LTO NOTIFY PGO UTF8PROC XDG
OPTIONS_DEFAULT=LTO NOTIFY PGO UTF8PROC XDG
OPTIONS_EXCLUDE+= ${CC:T:Mgcc*:C/.+/LTO/} # undefined reference to `xstrdup'
-OPTIONS_EXCLUDE_powerpc64= ${"${/usr/bin/ld:L:tA}"==/usr/bin/ld.lld:?LTO:} # https://github.com/llvm/llvm-project/issues/46697
-OPTIONS_EXCLUDE_FreeBSD_12= ${WAYLAND_DISPLAY:UPGO} # ./pgo hangs
DOCS_BUILD_DEPENDS= scdoc:textproc/scdoc
DOCS_MESON_ENABLED= docs
@@ -74,7 +73,9 @@ post-patch:
.if !defined(DEFAULT_POST_BUILD)
post-build-PGO-on:
(cd ${BUILD_WRKSRC} && ./tests/test-config) # -Wbackend-plugin/-Wmissing-profile
+ (cd ${BUILD_WRKSRC} && ./utils/xtgettcap) # -Wbackend-plugin/-Wmissing-profile
(cd ${BUILD_WRKSRC} && ./${PORTNAME}client --version) # -Wbackend-plugin/-Wmissing-profile
+ (cd ${BUILD_WRKSRC} && ./${PORTNAME} --version) # -Wbackend-plugin/-Wmissing-profile
.if defined(WAYLAND_DISPLAY)
# Likely a local build, so optimize for the current config
(cd ${BUILD_WRKSRC} && LC_ALL=en_US.UTF-8 ./${PORTNAME} ${PYTHON_CMD} \