aboutsummaryrefslogtreecommitdiff
path: root/x11/konsole
diff options
context:
space:
mode:
Diffstat (limited to 'x11/konsole')
-rw-r--r--x11/konsole/Makefile1
-rw-r--r--x11/konsole/files/patch-src_main.cpp13
2 files changed, 14 insertions, 0 deletions
diff --git a/x11/konsole/Makefile b/x11/konsole/Makefile
index e46f8972a3d2..8154e40b94cb 100644
--- a/x11/konsole/Makefile
+++ b/x11/konsole/Makefile
@@ -2,6 +2,7 @@
PORTNAME= konsole
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-applications # kde kde-applications-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/x11/konsole/files/patch-src_main.cpp b/x11/konsole/files/patch-src_main.cpp
new file mode 100644
index 000000000000..ed28776d6705
--- /dev/null
+++ b/x11/konsole/files/patch-src_main.cpp
@@ -0,0 +1,13 @@
+diff --git a/src/main.cpp b/src/main.cpp
+index 06f3ce491dbf58270ab5df38794903dab002bf39..b477109fd1a6bf4315efe21dcaaf89570fbd392d 100644
+--- src/main.cpp
++++ src/main.cpp
+@@ -167,6 +167,8 @@ extern "C" int Q_DECL_EXPORT kdemain(int argc, char *argv[])
+ if (!Konsole::KonsoleSettings::useSingleInstance()
+ && !parser->isSet(QStringLiteral("new-tab"))) {
+ startupOption = KDBusService::Multiple;
++ } else if (Konsole::KonsoleSettings::useSingleInstance()) {
++ startupOption = KDBusService::Unique;
+ }
+
+ atexit(deleteQApplication);