aboutsummaryrefslogtreecommitdiff
path: root/x11/ulauncher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/ulauncher/Makefile')
-rw-r--r--x11/ulauncher/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/x11/ulauncher/Makefile b/x11/ulauncher/Makefile
index 2ca34d62af6a..a092af60b0f1 100644
--- a/x11/ulauncher/Makefile
+++ b/x11/ulauncher/Makefile
@@ -1,18 +1,20 @@
PORTNAME= ulauncher
-PORTVERSION= 5.14.7
+PORTVERSION= 5.15.6
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= https://github.com/Ulauncher/Ulauncher/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Advanced graphical application launcher
+WWW= https://ulauncher.io/
LICENSE= GPLv3
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.18:devel/py-python-distutils-extra@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyinotify>=0:devel/py-pyinotify@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}python-Levenshtein>=0:devel/py-python-Levenshtein@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Levenshtein>=0:devel/py-Levenshtein@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}websocket-client>=0:www/py-websocket-client@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${PY_FLAVOR} \
@@ -21,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR} \
${LOCALBASE}/share/gir-1.0/WebKit2-4.0.gir:www/webkit2-gtk3 \
wmctrl:x11/wmctrl
-USES= gettext-tools gnome python:3.6+
+USES= gettext-tools gnome python
USE_GNOME= gtk30 intltool pygobject3
USE_PYTHON= autoplist distutils noflavors
WRKSRC= ${WRKDIR}/${PORTNAME}