aboutsummaryrefslogtreecommitdiff
path: root/x11/xclip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xclip/Makefile')
-rw-r--r--x11/xclip/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/x11/xclip/Makefile b/x11/xclip/Makefile
index b8715703cddb..37c154683106 100644
--- a/x11/xclip/Makefile
+++ b/x11/xclip/Makefile
@@ -1,31 +1,35 @@
PORTNAME= xclip
-PORTVERSION= 0.13
+DISTVERSION= 0.13-82
+DISTVERSIONSUFFIX= -gb372f73
+PORTREVISION= 1
CATEGORIES= x11
MAINTAINER= eduardo@FreeBSD.org
COMMENT= Interface to X selections ("the clipboard") from the command line
+WWW= https://github.com/astrand/xclip
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= autoreconf gmake iconv xorg
-
USE_GITHUB= yes
GH_ACCOUNT= astrand
-
USE_XORG= x11 xmu
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= ac_cv_header_X11_Xmu_Atoms_h=yes \
- ac_cv_header_X11_Intrinsic_h=yes \
+CONFIGURE_ENV+= ac_cv_header_X11_Intrinsic_h=yes \
+ ac_cv_header_X11_Xmu_Atoms_h=yes \
ac_cv_lib_Xmu_XmuClientWindow=yes
-PLIST_FILES= bin/xclip bin/xclip-copyfile bin/xclip-cutfile \
+PLIST_FILES= bin/xclip \
+ bin/xclip-copyfile \
+ bin/xclip-cutfile \
bin/xclip-pastefile \
- man/man1/xclip.1.gz man/man1/xclip-copyfile.1.gz
+ share/man/man1/xclip-copyfile.1.gz \
+ share/man/man1/xclip.1.gz
PORTDOCS= README
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}