aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/nwg-dock/Makefile43
-rw-r--r--x11/nwg-dock/distinfo19
-rw-r--r--x11/nwg-dock/pkg-descr6
4 files changed, 69 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 35eb5d664de1..fa49a0f12506 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -246,6 +246,7 @@
SUBDIR += nvidia-secondary-driver-390
SUBDIR += nvidia-settings
SUBDIR += nvidia-xconfig
+ SUBDIR += nwg-dock
SUBDIR += nwg-drawer
SUBDIR += nwg-launchers
SUBDIR += nxcomp
diff --git a/x11/nwg-dock/Makefile b/x11/nwg-dock/Makefile
new file mode 100644
index 000000000000..4b382a3026c2
--- /dev/null
+++ b/x11/nwg-dock/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= nwg-dock
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.5
+CATEGORIES= x11
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= GTK3-based dock for sway
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libgtk-layer-shell.so:x11-toolkits/gtk-layer-shell
+
+USES= gnome go:modules pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30
+GH_ACCOUNT= nwg-piotr
+GH_TAGNAME= b808f01 # from version bump in main.go
+GH_TUPLE= allan-simon:go-singleinstance:d0997106ab37:allan_simon_go_singleinstance/vendor/github.com/allan-simon/go-singleinstance \
+ dlasky:gotk3-layershell:5cca0b819261:dlasky_gotk3_layershell/vendor/github.com/dlasky/gotk3-layershell \
+ golang:sync:56d357773e84:golang_sync/vendor/golang.org/x/sync \
+ gotk3:gotk3:v0.6.0:gotk3_gotk3/vendor/github.com/gotk3/gotk3 \
+ joshuarubin:go-sway:v0.0.4:joshuarubin_go_sway/vendor/github.com/joshuarubin/go-sway \
+ joshuarubin:lifecycle:v1.0.0:joshuarubin_lifecycle/vendor/github.com/joshuarubin/lifecycle \
+ uber-go:atomic:v1.3.2:uber_go_atomic/vendor/go.uber.org/atomic \
+ uber-go:multierr:v1.1.0:uber_go_multierr/vendor/go.uber.org/multierr
+CGO_LDFLAGS+= -Wl,--as-needed # harfbuzz, freetype2
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= images *.css
+
+post-patch:
+# Respect PREFIX for *.desktop
+ @${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},' \
+ ${WRKSRC}/tools.go
+
+post-install:
+# Based on install from WRKSRC/Makefile
+ @${CP} -p ${WRKSRC}/config/*.css ${WRKSRC}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" \
+ ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/x11/nwg-dock/distinfo b/x11/nwg-dock/distinfo
new file mode 100644
index 000000000000..cda5b37c2e7b
--- /dev/null
+++ b/x11/nwg-dock/distinfo
@@ -0,0 +1,19 @@
+TIMESTAMP = 1624058743
+SHA256 (nwg-piotr-nwg-dock-v0.1.5-b808f01_GH0.tar.gz) = 8b947b9685fed2600a28707fd9a3f5823309b79c57f34856f99e23b4f8b1fa6a
+SIZE (nwg-piotr-nwg-dock-v0.1.5-b808f01_GH0.tar.gz) = 3238269
+SHA256 (allan-simon-go-singleinstance-d0997106ab37_GH0.tar.gz) = f8cee874873fe9fc1a81e8a7ca83df85c57aa86279c09cb8cba10d5feb7ed295
+SIZE (allan-simon-go-singleinstance-d0997106ab37_GH0.tar.gz) = 2819
+SHA256 (dlasky-gotk3-layershell-5cca0b819261_GH0.tar.gz) = a4548130c9fcc87302568b382fc4952aaaea262e04540480dddfd220f878c4fc
+SIZE (dlasky-gotk3-layershell-5cca0b819261_GH0.tar.gz) = 2282
+SHA256 (golang-sync-56d357773e84_GH0.tar.gz) = b30ecf4394f01a492423b41e3815d84711c29d679ee4dd5118fc2c9bcf433b3f
+SIZE (golang-sync-56d357773e84_GH0.tar.gz) = 16832
+SHA256 (gotk3-gotk3-v0.6.0_GH0.tar.gz) = 73e33cf291cc7d071e29af15482c4b45794ad614d6dcecac716df0959126a0ce
+SIZE (gotk3-gotk3-v0.6.0_GH0.tar.gz) = 272701
+SHA256 (joshuarubin-go-sway-v0.0.4_GH0.tar.gz) = bde4f59a99937f5a4128cdbc8c06107a41f72324a88de6d1d0cd666df0750820
+SIZE (joshuarubin-go-sway-v0.0.4_GH0.tar.gz) = 9158
+SHA256 (joshuarubin-lifecycle-v1.0.0_GH0.tar.gz) = 01ae9623078c568cefbda7c2dd973024382cdbf598f5efa4ac5578bb4bd0dff7
+SIZE (joshuarubin-lifecycle-v1.0.0_GH0.tar.gz) = 7265
+SHA256 (uber-go-atomic-v1.3.2_GH0.tar.gz) = ee2ec763758d8ab2095ee927086a1ed057212fa27660614448d4bbcbdc4ffe61
+SIZE (uber-go-atomic-v1.3.2_GH0.tar.gz) = 8047
+SHA256 (uber-go-multierr-v1.1.0_GH0.tar.gz) = 45405583513302d57d4715fada5ef8c8dbd9c9992956f2d0faa8758d9d885851
+SIZE (uber-go-multierr-v1.1.0_GH0.tar.gz) = 9234
diff --git a/x11/nwg-dock/pkg-descr b/x11/nwg-dock/pkg-descr
new file mode 100644
index 000000000000..a839f9f4d3e2
--- /dev/null
+++ b/x11/nwg-dock/pkg-descr
@@ -0,0 +1,6 @@
+Fully configurable (with command line arguments and css) dock, written
+in Go, aimed exclusively at sway Wayland compositor. It features
+pinned buttons, task buttons, the workspace switcher and the launcher
+button. By default the launcher starts nwg-drawer or nwggrid (if found).
+
+WWW: https://github.com/nwg-piotr/nwg-dock