aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/kf5-frameworkintegration/Makefile5
-rw-r--r--x11/kf5-kdelibs4support/Makefile3
-rw-r--r--x11/kf5-kinit/Makefile3
-rw-r--r--x11/kf5-krunner/Makefile5
-rw-r--r--x11/kf5-plasma-framework/Makefile3
5 files changed, 12 insertions, 7 deletions
diff --git a/x11/kf5-frameworkintegration/Makefile b/x11/kf5-frameworkintegration/Makefile
index 6e49b65b6478..2d136a3637b5 100644
--- a/x11/kf5-frameworkintegration/Makefile
+++ b/x11/kf5-frameworkintegration/Makefile
@@ -2,6 +2,7 @@
PORTNAME= frameworkintegration
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -9,9 +10,9 @@ COMMENT= KF5 workspace and cross-framework integration plugins
USES= cmake compiler:c++11-lib gettext kde:5 pkgconfig \
qt:5 tar:xz
-USE_KDE= auth codecs config configwidgets coreaddons ecm i18n \
+USE_KDE= auth attica codecs config configwidgets coreaddons ecm i18n \
iconthemes kio newstuff notifications package widgetsaddons
-USE_QT= buildtools_build core dbus gui qmake_build widgets \
+USE_QT= buildtools_build core dbus gui network qmake_build widgets \
x11extras xml
USE_XORG= xcb xcursor
diff --git a/x11/kf5-kdelibs4support/Makefile b/x11/kf5-kdelibs4support/Makefile
index b4cb59d327e4..dae2568fcaeb 100644
--- a/x11/kf5-kdelibs4support/Makefile
+++ b/x11/kf5-kdelibs4support/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kdelibs4support
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -18,7 +19,7 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
widgetsaddons windowsystem xmlgui \
designerplugin_build designerplugin_run \
itemmodels_run
-USE_QT= buildtools_build core dbus designer gui network \
+USE_QT= buildtools_build concurrent core dbus designer gui network \
printsupport qmake_build svg testlib widgets \
x11extras xml
USE_XORG= ice sm x11 xext
diff --git a/x11/kf5-kinit/Makefile b/x11/kf5-kinit/Makefile
index 521052fba059..19d94497b1b7 100644
--- a/x11/kf5-kinit/Makefile
+++ b/x11/kf5-kinit/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kinit
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ COMMENT= KF5 process launcher to speed up launching KDE applications
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= completion config coreaddons crash doctools ecm i18n \
jobwidgets kio service widgetsaddons windowsystem
-USE_QT= buildtools_build core dbus gui network qmake_build widgets
+USE_QT= buildtools_build concurrent core dbus gui network qmake_build widgets
USE_XORG= x11 xcb
.include <bsd.port.mk>
diff --git a/x11/kf5-krunner/Makefile b/x11/kf5-krunner/Makefile
index e590db539094..814c99bbedfa 100644
--- a/x11/kf5-krunner/Makefile
+++ b/x11/kf5-krunner/Makefile
@@ -2,6 +2,7 @@
PORTNAME= krunner
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,7 @@ COMMENT= KF5 parallelized query system
USES= cmake compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= config coreaddons ecm i18n kio package plasma-framework \
service solid threadweaver
-USE_QT= buildtools_build core declarative gui network qmake_build \
- widgets
+USE_QT= buildtools_build concurrent core dbus declarative gui \
+ network qmake_build widgets
.include <bsd.port.mk>
diff --git a/x11/kf5-plasma-framework/Makefile b/x11/kf5-plasma-framework/Makefile
index c1227fb255e8..9da0432c0810 100644
--- a/x11/kf5-plasma-framework/Makefile
+++ b/x11/kf5-plasma-framework/Makefile
@@ -2,6 +2,7 @@
PORTNAME= plasma-framework
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -14,7 +15,7 @@ USE_KDE= activities archive auth codecs completion config \
guiaddons i18n iconthemes jobwidgets kirigami2 kio package \
notifications service wayland windowsystem xmlgui kdeclarative \
widgetsaddons
-USE_QT= buildtools_build core dbus declarative gui network qmake_build \
+USE_QT= buildtools_build concurrent core dbus declarative gui network qmake_build \
script sql svg widgets x11extras xml
USE_XORG= ice sm x11 xcb xext xrandr