aboutsummaryrefslogtreecommitdiff
path: root/archivers/unarchiver/Makefile
blob: 29990f57186ad94a062629597e0a0cadbdb3360f (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>

PORTNAME=	unar
PORTVERSION=	1.10.1
PORTREVISION=	19
CATEGORIES=	archivers gnustep
MASTER_SITES=	http://wakaba.c3.cx/releases/TheUnarchiver/
DISTNAME=	${PORTNAME}${PORTVERSION}_src

MAINTAINER=	danfe@FreeBSD.org
COMMENT=	Unarchiver for a vast variety of file formats

LICENSE=	LGPL21
LICENSE_FILE=	${WRKSRC}/License.txt

BROKEN_powerpc64=	fails to compile: Your gnustep-base was configured for the objc-nonfragile-abi but you are not using it now.

# XXX: USES=gnustep overrides MAKEFILE we set below, so depend explicitly
LIB_DEPENDS=	libgnustep-base.so:lang/gnustep-base \
		libicuuc.so:devel/icu \
		libwavpack.so:audio/wavpack

USES=		gmake zip

MAKEFILE=	Makefile.freebsd
WRKSRC=		${WRKDIR}/The\ Unarchiver
BUILD_WRKSRC=	${WRKSRC}/XADMaster

PLIST_FILES=	bin/lsar bin/unar man/man1/lsar.1.gz man/man1/unar.1.gz
PORTDOCS=	README.md
PORTEXAMPLES=	lsar.bash_completion unar.bash_completion

OPTIONS_DEFINE=	DOCS EXAMPLES

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/XADMaster/??ar ${STAGEDIR}${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/Extra/??ar.1 ${STAGEDIR}${MANPREFIX}/man/man1

do-install-DOCS-on:
	@${MKDIR} ${STAGEDIR}${DOCSDIR}
	${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}

do-install-EXAMPLES-on:
	@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
	${INSTALL_DATA} ${WRKSRC}/Extra/??ar.bash_completion \
		${STAGEDIR}${EXAMPLESDIR}

.include <bsd.port.mk>