aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoshihiro Takahashi <nyan@FreeBSD.org>2026-06-05 13:14:06 +0000
committerYoshihiro Takahashi <nyan@FreeBSD.org>2026-06-21 10:51:10 +0000
commit9f9f0d3d9e1c9c9416b12625d357dd6f80d5f9be (patch)
tree860d92618b99c34f8f21dc9b7d3830689e641726
parentcee36a5e003c90659f274a2f20699543c73f2d34 (diff)
protocols: Update with IANA list
- Update /etc/protocols with IANA list updated 2026-03-09. - Document that 240 (pfsync) is not assigned by IANA. - Document deprecated protocols. PR: 295739 Reviewed by: des MFC after: 1 week Differential Revision: https://reviews.freebsd.org/D57445 (cherry picked from commit e3fa020202d8e040242016bda275dde83c058549)
-rw-r--r--lib/libc/net/protocols17
1 files changed, 11 insertions, 6 deletions
diff --git a/lib/libc/net/protocols b/lib/libc/net/protocols
index 9810356b8973..cf64703ce06a 100644
--- a/lib/libc/net/protocols
+++ b/lib/libc/net/protocols
@@ -19,7 +19,7 @@ igp 9 IGP # any private interior gateway (Cisco: for IGRP)
bbn-rcc 10 BBN-RCC-MON # BBN RCC Monitoring
nvp 11 NVP-II # Network Voice Protocol
pup 12 PUP # PARC universal packet protocol
-argus 13 ARGUS # ARGUS
+argus 13 ARGUS # ARGUS (deprecated)
emcon 14 EMCON # EMCON
xnet 15 XNET # Cross Net Debugger
chaos 16 CHAOS # Chaos
@@ -59,7 +59,7 @@ bna 49 BNA # BNA
esp 50 ESP # encapsulating security payload
ah 51 AH # authentication header
i-nlsp 52 I-NLSP # Integrated Net Layer Security TUBA
-swipe 53 SWIPE # IP with Encryption
+swipe 53 SWIPE # IP with Encryption (deprecated)
narp 54 NARP # NBMA Address Resolution Protocol
mobile 55 MOBILE # IP Mobility
tlsp 56 TLSP # Transport Layer Security Protocol
@@ -102,7 +102,7 @@ larp 91 LARP # Locus Address Resolution Protocol
mtp 92 MTP # Multicast Transport Protocol
ax.25 93 AX.25 # AX.25 Frames
ipip 94 IPIP # Yet Another IP encapsulation
-micp 95 MICP # Mobile Internetworking Control Pro.
+micp 95 MICP # Mobile Internetworking Control Pro. (deprecated)
scc-sp 96 SCC-SP # Semaphore Communications Sec. Pro.
etherip 97 ETHERIP # Ethernet-within-IP Encapsulation
encap 98 ENCAP # Yet Another IP encapsulation
@@ -129,7 +129,7 @@ stp 118 STP # Schedule Transfer Protocol
srp 119 SRP # SpectraLink Radio Protocol
uti 120 UTI # UTI
smp 121 SMP # Simple Message Protocol
-sm 122 SM # SM
+sm 122 SM # SM (deprecated)
ptp 123 PTP # Performance Transparency Protocol
isis 124 ISIS # ISIS over IPv4
fire 125 FIRE
@@ -150,8 +150,13 @@ hip 139 HIP # Host Identity Protocol (RFC5201)
shim6 140 SHIM6 # Shim6 Protocol (RFC5533)
wesp 141 WESP # Wrapped Encapsulating Security Payload (RFC5840)
rohc 142 ROHC # Robust Header Compression (RFC5858)
-# 138-254 # Unassigned
-pfsync 240 PFSYNC # PF Synchronization
+ethernet 143 Ethernet # Ethernet (RFC8986)
+aggfrag 144 AGGFRAG # AGGFRAG encapsulation payload for ESP (RFC9347)
+nsh 145 NSH # Network Service Header (RFC9491)
+homa 146 Homa # Homa
+bit-emu 147 BIT-EMU # Bit-stream Emulation (RFC9801)
+# 148-252 # Unassigned
+pfsync 240 PFSYNC # PF Synchronization [non IANA]
# 253-254 # Use for experimentation and testing (RFC3692)
# 255 # Reserved
divert 258 DIVERT # Divert pseudo-protocol [non IANA]