aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/lang
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2016-01-13 20:06:56 +0000
committerDimitry Andric <dim@FreeBSD.org>2016-01-13 20:06:56 +0000
commit7fed546d1996271dabc7cf71d4d033125c4da4ee (patch)
tree2b6dc7dcb4a6380cb331aded15f5a81c0038e194 /packages/Python/lldbsuite/test/lang
parent9e6d35490a6542f9c97607f93c2ef8ca8e03cbcc (diff)
downloadsrc-7fed546d1996271dabc7cf71d4d033125c4da4ee.tar.gz
src-7fed546d1996271dabc7cf71d4d033125c4da4ee.zip
Vendor import of lldb trunk r257626:vendor/lldb/lldb-trunk-r257626
Notes
Notes: svn path=/vendor/lldb/dist/; revision=293848 svn path=/vendor/lldb/lldb-trunk-r257626/; revision=293849; tag=vendor/lldb/lldb-trunk-r257626
Diffstat (limited to 'packages/Python/lldbsuite/test/lang')
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/global_ptrs/Makefile6
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/global_ptrs/TestGlobalObjects.py53
-rw-r--r--packages/Python/lldbsuite/test/lang/objc/global_ptrs/main.m11
3 files changed, 70 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/objc/global_ptrs/Makefile b/packages/Python/lldbsuite/test/lang/objc/global_ptrs/Makefile
new file mode 100644
index 000000000000..a1608fe5a664
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/objc/global_ptrs/Makefile
@@ -0,0 +1,6 @@
+LEVEL = ../../../make
+
+OBJC_SOURCES := main.m
+LDFLAGS = $(CFLAGS) -lobjc -framework Foundation
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/lang/objc/global_ptrs/TestGlobalObjects.py b/packages/Python/lldbsuite/test/lang/objc/global_ptrs/TestGlobalObjects.py
new file mode 100644
index 000000000000..c4c581b9240f
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/objc/global_ptrs/TestGlobalObjects.py
@@ -0,0 +1,53 @@
+"""Test that a global ObjC object found before the process is started updates correctly."""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+import lldbsuite.test.lldbutil as lldbutil
+from lldbsuite.test.lldbtest import *
+
+class TestObjCGlobalVar(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ self.main_source = lldb.SBFileSpec("main.m")
+
+ @skipUnlessDarwin
+ @add_test_categories(['pyapi'])
+ def test_with_python_api(self):
+ """Test that a global ObjC object found before the process is started updates correctly."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ bkpt = target.BreakpointCreateBySourceRegex ('NSLog', self.main_source)
+ self.assertTrue(bkpt, VALID_BREAKPOINT)
+
+ # Before we launch, make an SBValue for our global object pointer:
+ g_obj_ptr = target.FindFirstGlobalVariable("g_obj_ptr")
+ self.assertTrue(g_obj_ptr.GetError().Success(), "Made the g_obj_ptr")
+ self.assertTrue(g_obj_ptr.GetValueAsUnsigned(10) == 0, "g_obj_ptr is initially null")
+
+ # Now launch the process, and do not stop at entry point.
+ process = target.LaunchSimple (None, None, self.get_process_working_directory())
+
+ self.assertTrue(process, PROCESS_IS_VALID)
+
+ # The stop reason of the thread should be breakpoint.
+ threads = lldbutil.get_threads_stopped_at_breakpoint (process, bkpt)
+ if len(threads) != 1:
+ self.fail ("Failed to stop at breakpoint 1.")
+
+ thread = threads[0]
+
+ dyn_value = g_obj_ptr.GetDynamicValue(lldb.eDynamicCanRunTarget)
+ self.assertTrue(dyn_value.GetError().Success(), "Dynamic value is valid")
+ self.assertTrue(dyn_value.GetObjectDescription() == "Some NSString")
diff --git a/packages/Python/lldbsuite/test/lang/objc/global_ptrs/main.m b/packages/Python/lldbsuite/test/lang/objc/global_ptrs/main.m
new file mode 100644
index 000000000000..977a984e06e0
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/objc/global_ptrs/main.m
@@ -0,0 +1,11 @@
+#import <Foundation/Foundation.h>
+
+id g_obj_ptr = nil;
+
+int
+main()
+{
+ g_obj_ptr = @"Some NSString";
+ NSLog(@"My string was %@.", g_obj_ptr);
+ return 0;
+}