aboutsummaryrefslogtreecommitdiff
path: root/sys/bsm/Makefile.am
diff options
context:
space:
mode:
authorRobert Watson <rwatson@FreeBSD.org>2008-11-13 00:04:15 +0000
committerRobert Watson <rwatson@FreeBSD.org>2008-11-13 00:04:15 +0000
commita5c6cfa00d9aad0a0da65a940ac6d782edfa841e (patch)
treedf6eec05070bdfdd7ef98d7164381dfbe7d070c5 /sys/bsm/Makefile.am
parent2708261ab67b9e3822fdd9ea8d8e1acf5c6bbbc0 (diff)
downloadsrc-a5c6cfa00d9aad0a0da65a940ac6d782edfa841e.tar.gz
src-a5c6cfa00d9aad0a0da65a940ac6d782edfa841e.zip
Vendor import of OpenBSM 1.1 alpha2, which incorporates the followingvendor/openbsm/1.1-ALPHA-2
changes since the last imported OpenBSM release: OpenBSM 1.1 alpha 2 - Include files in OpenBSM are now broken out into two parts: library builds required solely for user space, and system includes, which may also be required for use in the kernels of systems integrating OpenBSM. Submitted by Stacey Son. - Configure option --with-native-includes allows forcing the use of native include for system includes, rather than the versions bundled with OpenBSM. This is intended specifically for platforms that ship OpenBSM, have adapted versions of the system includes in a kernel source tree, and will use the OpenBSM build infrastructure with an unmodified OpenBSM distribution, allowing the customized system includes to be used with the OpenBSM build. Submitted by Stacey Son. - Various strcpy()'s/strcat()'s have been changed to strlcpy()'s/strlcat()'s or asprintf(). Added compat/strlcpy.h for Linux. - Remove compatibility defines for old Darwin token constant names; now only BSM token names are provided and used. - Add support for extended header tokens, which contain space for information on the host generating the record. - Add support for setting extended host information in the kernel, which is used for setting host information in extended header tokens. The audit_control file now supports a "host" parameter which can be used by auditd to set the information; if not present, the kernel parameters won't be set and auditd uses unextended headers for records that it generates. OpenBSM 1.1 alpha 1 - Add option to auditreduce(1) which allows users to invert sense of matching, such that BSM records that do not match, are selected. - Fix bug in audit_write() where we commit an incomplete record in the event there is an error writing the subject token. This was submitted by Diego Giagio. - Build support for Mac OS X 10.5.1 submitted by Eric Hall. - Fix a bug which resulted in host XML attributes not beingguments so that const strings can be passed as arguments to tokens. This patch was submitted by Xin LI. - Modify the -m option so users can select more then one audit event. - For Mac OS X, added Mach IPC support for audit trigger messages. - Fixed a bug in getacna() which resulted in a locking problem on Mac OS X. - Added LOG_PERROR flag to openlog when -d option is used with auditd. - AUE events added for Mac OS X Leopard system calls. Obtained from: TrustedBSD Project Sponsored by: Apple Inc.
Notes
Notes: svn path=/vendor/openbsm/dist/; revision=184902 svn path=/vendor/openbsm/1.1-ALPHA-2/; revision=184903; tag=vendor/openbsm/1.1-ALPHA-2
Diffstat (limited to 'sys/bsm/Makefile.am')
-rw-r--r--sys/bsm/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/sys/bsm/Makefile.am b/sys/bsm/Makefile.am
new file mode 100644
index 000000000000..b3c7805bca8e
--- /dev/null
+++ b/sys/bsm/Makefile.am
@@ -0,0 +1,14 @@
+#
+# $P4: //depot/projects/trustedbsd/openbsm/sys/bsm/Makefile.am#1 $
+#
+
+
+if ! USE_NATIVE_INCLUDES
+openbsmdir = $(includedir)/bsm
+
+openbsm_HEADERS = \
+ audit.h \
+ audit_internal.h \
+ audit_kevents.h \
+ audit_record.h
+endif