aboutsummaryrefslogtreecommitdiff
path: root/test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2014-11-24 09:15:30 +0000
committerDimitry Andric <dim@FreeBSD.org>2014-11-24 09:15:30 +0000
commit9f4dbff6669c8037f3b036bcf580d14f1a4f12a5 (patch)
tree47df2c12b57214af6c31e47404b005675b8b7ffc /test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp
parentf73d5f23a889b93d89ddef61ac0995df40286bb8 (diff)
downloadsrc-vendor/clang/clang-release_350-r216957.tar.gz
src-vendor/clang/clang-release_350-r216957.zip
Vendor import of clang RELEASE_350/final tag r216957 (effectively, 3.5.0 release):vendor/clang/clang-release_350-r216957
Diffstat (limited to 'test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp')
-rw-r--r--test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp b/test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp
index 93f8ff1697bf..7eb5e3744d18 100644
--- a/test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp
+++ b/test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp
@@ -24,14 +24,14 @@ template int pi0 = 10; // expected-error {{variable cannot be defined in an expl
#endif
template<typename T>
-T pi1 = T(3.1415926535897932385);
+T pi1 = T(3.1415926535897932385); // expected-note 0-2 {{here}}
// Should recover as if specialization
template float pi1<float> = 1.0; // expected-error {{explicit template instantiation cannot have a definition; if this definition is meant to be an explicit specialization, add '<>' after the 'template' keyword}}
#ifndef FIXING
namespace expected_global {
- template<> double pi1<double> = 1.5; // expected-error {{no variable template matches specialization}}
+ template<> double pi1<double> = 1.5; // expected-error {{variable template specialization of 'pi1' must originally be declared in the global scope}}
template int pi1<int> = 10; // expected-error {{explicit template instantiation cannot have a definition; if this definition is meant to be an explicit specialization, add '<>' after the 'template' keyword}} \
- expected-error {{no variable template matches specialization}}
+ expected-error {{variable template specialization of 'pi1' must originally be declared in the global scope}}
}
#endif