aboutsummaryrefslogtreecommitdiff
path: root/Ada95/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'Ada95/configure.in')
-rw-r--r--Ada95/configure.in31
1 files changed, 6 insertions, 25 deletions
diff --git a/Ada95/configure.in b/Ada95/configure.in
index 21624e1521cf..3c3c1b156155 100644
--- a/Ada95/configure.in
+++ b/Ada95/configure.in
@@ -1,5 +1,6 @@
dnl***************************************************************************
-dnl Copyright (c) 2010-2019,2020 Free Software Foundation, Inc. *
+dnl Copyright 2018-2019,2020 Thomas E. Dickey *
+dnl Copyright 2010-2016,2018 Free Software Foundation, Inc. *
dnl *
dnl Permission is hereby granted, free of charge, to any person obtaining a *
dnl copy of this software and associated documentation files (the *
@@ -28,7 +29,7 @@ dnl***************************************************************************
dnl
dnl Author: Thomas E. Dickey
dnl
-dnl $Id: configure.in,v 1.74 2020/01/11 23:33:38 tom Exp $
+dnl $Id: configure.in,v 1.76 2020/02/08 21:03:20 tom Exp $
dnl Process this file with autoconf to produce a configure script.
dnl
dnl For additional information, see
@@ -37,7 +38,7 @@ dnl https://invisible-island.net/autoconf/my-autoconf.html
dnl
dnl ---------------------------------------------------------------------------
AC_PREREQ(2.52.20200111)
-AC_REVISION($Revision: 1.74 $)
+AC_REVISION($Revision: 1.76 $)
AC_INIT(gen/gen.c)
AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
@@ -214,27 +215,7 @@ fi
CF_HELP_MESSAGE(Fine-Tuning Your Configuration:)
### use option --enable-broken-linker to force on use of broken-linker support
-AC_MSG_CHECKING(if you want broken-linker support code)
-AC_ARG_ENABLE(broken_linker,
- [ --enable-broken_linker compile with broken-linker support code],
- [with_broken_linker=$enableval],
- [with_broken_linker=${BROKEN_LINKER:-no}])
-AC_MSG_RESULT($with_broken_linker)
-
-BROKEN_LINKER=0
-if test "$with_broken_linker" = yes ; then
- AC_DEFINE(BROKEN_LINKER)
- BROKEN_LINKER=1
-elif test "$DFT_LWR_MODEL" = shared ; then
- case $cf_cv_system_name in
- (cygwin*)
- AC_DEFINE(BROKEN_LINKER)
- BROKEN_LINKER=1
- CF_VERBOSE(cygwin linker is broken anyway)
- ;;
- esac
-fi
-AC_SUBST(BROKEN_LINKER)
+CF_ENABLE_BROKEN_LINKER
# Check to define _XOPEN_SOURCE "automatically"
CF_XOPEN_SOURCE(600)
@@ -457,7 +438,7 @@ AC_CHECK_LIB(bsd, gettimeofday,
esac
### Checks for header files.
-AC_CHECK_SIZEOF([signed char], 0)
+AC_CHECK_SIZEOF([signed char])
AC_STDC_HEADERS
AC_HEADER_DIRENT
AC_HEADER_TIME