aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am127
1 files changed, 43 insertions, 84 deletions
diff --git a/Makefile.am b/Makefile.am
index 02a66f7ac822..2908f96cd037 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,36 +1,12 @@
-## LIBOPTS_CHECK_NOBUILD works with Automake 1.10 now
-AUTOMAKE_OPTIONS = foreign 1.10
-ACLOCAL_AMFLAGS = -I m4 -I sntp/libopts/m4
+ACLOCAL_AMFLAGS = -I sntp/m4 -I sntp/libevent/m4 -I sntp/libopts/m4
NULL =
-SUBDIRS =
-SUBDIRS += \
- scripts \
- include \
- ElectricFence \
- libntp \
- sntp \
- libparse \
- ntpd \
- ntpdate \
- ntpdc \
- ntpq \
- ntpsnmpd \
- parseutil \
- adjtimed \
- clockstuff \
- kernel \
- util \
- $(NULL)
-
-DIST_SUBDIRS = \
+SUBDIRS = \
scripts \
include \
- ElectricFence \
libntp \
libparse \
- sntp \
ntpd \
ntpdate \
ntpdc \
@@ -41,9 +17,11 @@ DIST_SUBDIRS = \
clockstuff \
kernel \
util \
+ sntp \
+ tests \
$(NULL)
-DISTCHECK_CONFIGURE_FLAGS = -C
+DISTCHECK_CONFIGURE_FLAGS = -C --with-sntp
EXTRA_DIST = \
$(srcdir)/COPYRIGHT \
@@ -61,13 +39,9 @@ EXTRA_DIST = \
WHERE-TO-START \
bootstrap \
build \
- config.guess \
config.h.in \
- config.sub \
dot.emacs \
- excludes \
flock-build \
- install-sh \
packageinfo.sh \
readme.y2kfixes \
results.y2kfixes \
@@ -75,33 +49,48 @@ EXTRA_DIST = \
conf \
html \
lib/isc \
+ libjsmn \
ports \
\
- bincheck.mf \
- depsver.mf \
deps-ver \
- $(srcdir)/version \
- version.m4 \
\
$(NULL)
CLEANFILES =
DISTCLEANFILES = .gcc-warning
-ETAGS_ARGS = Makefile.am configure.ac
-
# HMS: Keep .gcc-warning first, as that way it gets printed first.
BUILT_SOURCES = \
.gcc-warning \
libtool \
+ html/.datecheck \
+ sntp/built-sources-only \
$(srcdir)/COPYRIGHT \
- $(srcdir)/version \
- $(srcdir)/version.m4 \
- $(srcdir)/include/version.def \
- $(srcdir)/include/version.texi \
$(srcdir)/.checkChangeLog \
$(NULL)
+.gcc-warning:
+ @echo "Compiling with GCC now generates lots of new warnings."
+ @echo " "
+ @echo "Don't be concerned. They're just warnings."
+ @echo " "
+ @echo "Don't send bug reports about the warnings, either."
+ @echo " "
+ @echo "Feel free to send patches that fix these warnings, though."
+ @echo " "
+ @sleep 1
+ @touch $@
+
+html/.datecheck: FRC.html
+ cd $(srcdir)/html && \
+ ../scripts/build/checkHtmlFileDates
+
+libtool: $(LIBTOOL_DEPS)
+ ./config.status --recheck
+
+sntp/built-sources-only: FRC.sntp
+ @cd sntp && $(MAKE) $(AM_MAKEFLAGS) built-sources-only
+
$(srcdir)/COPYRIGHT: $(srcdir)/html/copyright.html
{ echo "This file is automatically generated from html/copyright.html" ; \
lynx -dump $(srcdir)/html/copyright.html ;} > COPYRIGHT.new \
@@ -115,61 +104,31 @@ COPYRIGHT-please: $(srcdir)/COPYRIGHT
Rather than determine our $(srcdir) from sntp/Makefile.am \
COPYRIGHT-please serves as a fixed target.
-# HMS: The next bit is still suboptimal. If bk is present but this NTP
-# repo is not a bk repo, we'll get an error message from the prs command.
-# Unfortunately, I haven't found the necessary magic to redirect this error
-# output to /dev/null under ancient/unique shells like the one Ultrix uses.
-# We'll also get an error if srcdir or version is unwritable.
-$(srcdir)/version: FRC.version
- -(bk version) >/dev/null 2>&1 && \
- cd $(srcdir) && \
- x=`bk -R prs -hr+ -nd:I: ChangeSet` && \
- y=`cat version 2>/dev/null` || true && \
- case "$$x" in ''|$$y) ;; *) echo $$x > version ;; esac
-
-$(srcdir)/version.m4: $(srcdir)/packageinfo.sh
- TEMPDIR=`pwd` && export TEMPDIR && cd $(srcdir) && \
- ./scripts/genver version.m4
-
-$(srcdir)/include/version.def: $(srcdir)/packageinfo.sh
- TEMPDIR=`pwd` && export TEMPDIR && cd $(srcdir) && \
- ./scripts/genver include/version.def
-
-$(srcdir)/include/version.texi: $(srcdir)/packageinfo.sh
- TEMPDIR=`pwd` && export TEMPDIR && cd $(srcdir) && \
- ./scripts/genver include/version.texi
-
-$(srcdir)/.checkChangeLog: $(srcdir)/ChangeLog $(srcdir)/scripts/checkChangeLog
+$(srcdir)/.checkChangeLog: $(srcdir)/ChangeLog $(srcdir)/scripts/build/checkChangeLog
cd $(srcdir) && \
- ./scripts/checkChangeLog
-
-libtool: $(LIBTOOL_DEPS)
- ./config.status --recheck
+ ./scripts/build/checkChangeLog
dist-hook:
@find $(distdir) -type d -name SCCS -print | xargs rm -rf
-.gcc-warning:
- @echo "Compiling with GCC now generates lots of new warnings."
- @echo " "
- @echo "Don't be concerned. They're just warnings."
- @echo " "
- @echo "Don't send bug reports about the warnings, either."
- @echo " "
- @echo "Feel free to send patches that fix these warnings, though."
- @echo " "
- @sleep 1
- @touch $@
+install-data-local:
+ ( cd $(srcdir) && find html -name SCCS -prune -o -type d \
+ -exec $(INSTALL) -d $(DESTDIR)$(htmldir)/{} ";" )
+ ( cd $(srcdir) && find html -name SCCS -prune -o -type f \
+ -exec $(INSTALL_DATA) {} $(DESTDIR)$(htmldir)/{} ";" )
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(htmldir)/html
CommitLog: FRC.CommitLog
cd $(srcdir) \
&& $(PATH_TEST) -e CommitLog \
-a SCCS/s.ChangeSet -ot CommitLog \
- || scripts/genCommitLog
+ || scripts/build/genCommitLog
# HMS: The following seems to be a work-in-progress...
-CVO=`$(srcdir)/config.guess`
+CVO=`$(srcdir)/sntp/libevent/build-aux/config.guess`
.buildcvo:
echo "$(CVO)" > .buildcvo
@@ -192,7 +151,7 @@ BHOST=`(hostname || uname -n)`
echo " "; \
fi
-FRC.CommitLog FRC.distwarn FRC.checkcvo FRC.checkhost FRC.version:
+FRC.CommitLog FRC.checkcvo FRC.checkhost FRC.distwarn FRC.html FRC.sntp:
@: do-nothing action prevents any default
# HMS: what was I trying to do with this?