aboutsummaryrefslogtreecommitdiff
path: root/contrib/ncurses/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/ncurses/configure.in')
-rw-r--r--contrib/ncurses/configure.in31
1 files changed, 28 insertions, 3 deletions
diff --git a/contrib/ncurses/configure.in b/contrib/ncurses/configure.in
index 50892dd70320..8fa5e4eaaa56 100644
--- a/contrib/ncurses/configure.in
+++ b/contrib/ncurses/configure.in
@@ -28,14 +28,14 @@ dnl***************************************************************************
dnl
dnl Author: Thomas E. Dickey 1995-on
dnl
-dnl $Id: configure.in,v 1.429 2007/11/24 22:42:43 tom Exp $
+dnl $Id: configure.in,v 1.433 2008/04/12 23:39:06 tom Exp $
dnl Process this file with autoconf to produce a configure script.
dnl
dnl See http://invisible-island.net/autoconf/ for additional information.
dnl
dnl ---------------------------------------------------------------------------
AC_PREREQ(2.13.20020210)
-AC_REVISION($Revision: 1.429 $)
+AC_REVISION($Revision: 1.433 $)
AC_INIT(ncurses/base/lib_initscr.c)
AC_CONFIG_HEADER(include/ncurses_cfg.h:include/ncurses_cfg.hin)
@@ -969,8 +969,18 @@ if test "$with_ext_mouse" = yes ; then
fi
AC_SUBST(NCURSES_MOUSE_VERSION)
+# This is still experimental (20080329), but should ultimately be moved to
+# the script-block --with-normal, etc.
+CF_WITH_PTHREAD
+if test "$with_pthread" = "yes" ; then
+ AC_DEFINE(USE_PTHREADS)
+ enable_reentrant=yes
+fi
+
# Reentrant code has to be opaque; there's little advantage to making ncurses
-# opaque outside of that, so there is no --enable-opaque option.
+# opaque outside of that, so there is no --enable-opaque option. We can use
+# this option without --with-pthreads, but this will be always set for
+# pthreads.
AC_MSG_CHECKING(if you want experimental reentrant code)
AC_ARG_ENABLE(reentrant,
[ --enable-reentrant compile with experimental reentrant code],
@@ -1242,6 +1252,17 @@ CF_SIZECHANGE
CF_FUNC_MEMMOVE
CF_FUNC_POLL
+# special check for test/ditto.c
+CF_FUNC_OPENPTY
+if test "$cf_cv_func_openpty" != no ; then
+ AC_DEFINE_UNQUOTED(USE_OPENPTY_HEADER,<$cf_cv_func_openpty>)
+ AC_DEFINE(USE_XTERM_PTY)
+ if test "$cf_cv_lib_util" = yes ; then
+ TEST_LIBS="-lutil $TEST_LIBS"
+ fi
+fi
+AC_SUBST(TEST_LIBS)
+
if test "$with_hashed_db" != no ; then
AC_DEFINE(USE_HASHED_DB)
CF_HASHED_DB($with_hashed_db)
@@ -1629,6 +1650,10 @@ if test "$with_dlsym" = yes ; then
CF_REMOVE_LIB(TICS_LIST,$TICS_LIST,dl)
fi
+if test "$DFT_LWR_MODEL" = "libtool"; then
+ OBJEXT=lo
+fi
+
# needed for Ada95
TINFO_ARGS2=`echo "$TINFO_ARGS" | sed -e 's,-L\.\./,-L../../,'`
AC_SUBST(TINFO_ARGS2)