aboutsummaryrefslogtreecommitdiff
path: root/contrib/ntp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/ntp/Makefile.am')
-rw-r--r--contrib/ntp/Makefile.am52
1 files changed, 35 insertions, 17 deletions
diff --git a/contrib/ntp/Makefile.am b/contrib/ntp/Makefile.am
index ddf9956e6ba5..977643b3fd72 100644
--- a/contrib/ntp/Makefile.am
+++ b/contrib/ntp/Makefile.am
@@ -22,12 +22,15 @@ SUBDIRS = \
EXTRA_DIST = \
COPYRIGHT \
ChangeLog \
+ ChangeLog-4.1.0 \
NEWS \
NOTES.y2kfixes \
+ README.bk \
README.cvs \
README.des \
README.hackers \
README.rsa \
+ README.versions \
TODO \
WHERE-TO-START \
acconfig.h \
@@ -44,7 +47,8 @@ EXTRA_DIST = \
results.y2kfixes \
conf \
html \
- ports
+ ports \
+ version
DISTCLEANFILES = .warning
@@ -54,15 +58,40 @@ ETAGS_ARGS = Makefile.am configure.in acconfig.h
# HMS: make ports be the last directory...
# DIST_HOOK_DIRS = conf html scripts ports
-BUILT_SOURCES = $(srcdir)/COPYRIGHT
+# HMS: Keep .warning first, as that way it gets printed first.
+BUILT_SOURCES = .warning $(srcdir)/COPYRIGHT $(srcdir)/version
$(srcdir)/COPYRIGHT: html/copyright.htm
( echo "This file is automatically generated from html/copyright.htm" ; lynx -dump $(srcdir)/html/copyright.htm ) > $(srcdir)/COPYRIGHT.new && mv $(srcdir)/COPYRIGHT.new $(srcdir)/COPYRIGHT
+# HMS: The next bit is still suboptimal. If bk is present but this NTP
+# repo is not a bk repo, we'll get an error message from the prs command.
+# Unfortunately, I haven't found the necessary magic to redirect this error
+# output to /dev/null under ancient/unique shells like the one Ultrix uses.
+# We'll also get an error of srcdir or version is unwritable.
+$(srcdir)/version: FRC.version
+ -(bk version) >/dev/null 2>&1 && \
+ cd $(srcdir) && \
+ x=`bk -R prs -hr+ -nd:I: ChangeSet` && \
+ case "$$x" in '') ;; *) echo $$x > version ;; esac
+
dist-hook:
@find $(distdir) -type d -name CVS -print | xargs rm -rf
+ @find $(distdir) -type d -name SCCS -print | xargs rm -rf
+
+.warning:
+ @echo "Compiling with GCC now generates lots of new warnings."
+ @echo " "
+ @echo "Don't be concerned. They're just warnings."
+ @echo " "
+ @echo "Don't send bug reports about the warnings, either."
+ @echo " "
+ @echo "Feel free to send patches that fix these warnings, though."
+ @echo " "
+ @sleep 1
+ @touch .warning
-Makefile: .warning
+# HMS: The following seems to be a work-in-progress...
CVO=`$(srcdir)/config.guess`
@@ -87,18 +116,7 @@ BHOST=`(hostname || uname -n)`
echo " "; \
fi
-.warning:
- @echo "Compiling with GCC now generates lots of new warnings."
- @echo " "
- @echo "Don't be concerned. They're just warnings."
- @echo " "
- @echo "Don't send bug reports about the warnings, either."
- @echo " "
- @echo "Feel free to send patches that fix these warnings, though."
- @echo " "
- @sleep 1
- @touch .warning
-
-FRC.distwarn FRC.checkcvo FRC.checkhost:
+FRC.distwarn FRC.checkcvo FRC.checkhost FRC.version:
-dot.emacs: FRC.distwarn
+# HMS: what was I trying to do with this?
+#dot.emacs: FRC.distwarn