aboutsummaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/BuildingAJIT/Chapter2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/BuildingAJIT/Chapter2/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/BuildingAJIT/Chapter2/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/examples/Kaleidoscope/BuildingAJIT/Chapter2/CMakeLists.txt b/examples/Kaleidoscope/BuildingAJIT/Chapter2/CMakeLists.txt
new file mode 100644
index 000000000000..ea5bc05fa00a
--- /dev/null
+++ b/examples/Kaleidoscope/BuildingAJIT/Chapter2/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ Core
+ ExecutionEngine
+ InstCombine
+ Object
+ RuntimeDyld
+ ScalarOpts
+ Support
+ native
+ )
+
+add_kaleidoscope_chapter(BuildingAJIT-Ch2
+ toy.cpp
+ )
+
+export_executable_symbols(BuildingAJIT-Ch2)