aboutsummaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/BuildingAJIT/Chapter5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/BuildingAJIT/Chapter5/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/BuildingAJIT/Chapter5/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/examples/Kaleidoscope/BuildingAJIT/Chapter5/CMakeLists.txt b/examples/Kaleidoscope/BuildingAJIT/Chapter5/CMakeLists.txt
new file mode 100644
index 000000000000..d5b832b49550
--- /dev/null
+++ b/examples/Kaleidoscope/BuildingAJIT/Chapter5/CMakeLists.txt
@@ -0,0 +1,21 @@
+add_subdirectory(Server)
+
+set(LLVM_LINK_COMPONENTS
+ Analysis
+ Core
+ ExecutionEngine
+ InstCombine
+ Object
+ OrcJIT
+ RuntimeDyld
+ ScalarOpts
+ Support
+ TransformUtils
+ native
+ )
+
+add_kaleidoscope_chapter(BuildingAJIT-Ch5
+ toy.cpp
+ )
+
+export_executable_symbols(BuildingAJIT-Ch5)