aboutsummaryrefslogtreecommitdiff
path: root/examples/Kaleidoscope/Chapter8/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Kaleidoscope/Chapter8/CMakeLists.txt')
-rw-r--r--examples/Kaleidoscope/Chapter8/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/Kaleidoscope/Chapter8/CMakeLists.txt b/examples/Kaleidoscope/Chapter8/CMakeLists.txt
index f94ed7436189..d9b5cc421be3 100644
--- a/examples/Kaleidoscope/Chapter8/CMakeLists.txt
+++ b/examples/Kaleidoscope/Chapter8/CMakeLists.txt
@@ -1,8 +1,7 @@
set(LLVM_LINK_COMPONENTS
Core
ExecutionEngine
- MCJIT
- RuntimeDyld
+ Object
Support
native
)
@@ -10,3 +9,5 @@ set(LLVM_LINK_COMPONENTS
add_kaleidoscope_chapter(Kaleidoscope-Ch8
toy.cpp
)
+
+export_executable_symbols(Kaleidoscope-Ch8)