aboutsummaryrefslogtreecommitdiff
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index d20d77ef7ea5..e804fe720558 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -5,13 +5,13 @@ add_clang_library(clangAST
ASTConsumer.cpp
ASTContext.cpp
ASTDiagnostic.cpp
+ ASTDumper.cpp
ASTImporter.cpp
AttrImpl.cpp
CXXInheritance.cpp
Comment.cpp
CommentBriefParser.cpp
CommentCommandTraits.cpp
- CommentDumper.cpp
CommentLexer.cpp
CommentParser.cpp
CommentSema.cpp
@@ -22,6 +22,7 @@ add_clang_library(clangAST
DeclFriend.cpp
DeclGroup.cpp
DeclObjC.cpp
+ DeclOpenMP.cpp
DeclPrinter.cpp
DeclTemplate.cpp
DumpXML.cpp
@@ -45,7 +46,6 @@ add_clang_library(clangAST
RecordLayoutBuilder.cpp
SelectorLocationsKind.cpp
Stmt.cpp
- StmtDumper.cpp
StmtIterator.cpp
StmtPrinter.cpp
StmtProfile.cpp
@@ -64,10 +64,13 @@ add_dependencies(clangAST
ClangAttrClasses
ClangAttrList
ClangAttrImpl
+ ClangAttrDump
ClangCommentCommandInfo
+ ClangCommentCommandList
ClangCommentNodes
ClangCommentHTMLTags
ClangCommentHTMLTagsProperties
+ ClangCommentHTMLNamedCharacterReferences
ClangDeclNodes
ClangDiagnosticAST
ClangDiagnosticComment