aboutsummaryrefslogtreecommitdiff
path: root/lib/Index/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Index/CMakeLists.txt')
-rw-r--r--lib/Index/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/Index/CMakeLists.txt b/lib/Index/CMakeLists.txt
new file mode 100644
index 000000000000..5f818175ca5d
--- /dev/null
+++ b/lib/Index/CMakeLists.txt
@@ -0,0 +1,15 @@
+set(LLVM_NO_RTTI 1)
+
+add_clang_library(clangIndex
+ ASTLocation.cpp
+ Analyzer.cpp
+ DeclReferenceMap.cpp
+ Entity.cpp
+ GlobalSelector.cpp
+ Handlers.cpp
+ IndexProvider.cpp
+ Indexer.cpp
+ Program.cpp
+ ResolveLocation.cpp
+ SelectorMap.cpp
+ )