aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index dda87e41c0aa..f049288a1ae7 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -6,9 +6,13 @@ if BUILD_LINUX
SUBDIRS += libefi
endif
+# libnvpair is installed as part of the final build product
+# libzutil depends on it, so it must be compiled before libzutil
+SUBDIRS += libnvpair
+
# libzutil depends on libefi if present
SUBDIRS += libzutil libunicode
# These five libraries, which are installed as the final build product,
# incorporate the eight convenience libraries given above.
-SUBDIRS += libuutil libnvpair libzfs_core libzfs libzpool
+SUBDIRS += libuutil libzfs_core libzfs libzpool libzfsbootenv