aboutsummaryrefslogtreecommitdiff
path: root/lib/hcrypto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/hcrypto/Makefile.am')
-rw-r--r--lib/hcrypto/Makefile.am285
1 files changed, 175 insertions, 110 deletions
diff --git a/lib/hcrypto/Makefile.am b/lib/hcrypto/Makefile.am
index a9c688d28f21..878525c17d06 100644
--- a/lib/hcrypto/Makefile.am
+++ b/lib/hcrypto/Makefile.am
@@ -9,12 +9,19 @@ AM_CPPFLAGS += $(INCLUDE_openssl_crypto)
endif
AM_CPPFLAGS += -I$(top_srcdir)/lib/hx509 \
- -I$(srcdir)/libtommath -DUSE_HCRYPTO_LTM=1
+ -I$(srcdir)/libtommath -DUSE_HCRYPTO_LTM=1 \
+ -I$(srcdir)/x25519 \
+ -I$(srcdir)/..
+
+WFLAGS += $(WFLAGS_LITE) -Wno-error=unused-function
+# XXX: Make these not necessary:
+WFLAGS += -Wno-error=unused-result -Wno-error=deprecated-declarations
+WFLAGS += $(WFLAGS_UNUSED_BUT_SET_VAR)
lib_LTLIBRARIES = libhcrypto.la
check_LTLIBRARIES = libhctest.la
-libhcrypto_la_LDFLAGS = -version-info 5:0:1
+libhcrypto_la_LDFLAGS = -version-info 5:0:0
libhcrypto_la_LIBADD = \
$(top_builddir)/lib/asn1/libasn1.la \
$(LIB_dlopen) \
@@ -55,7 +62,7 @@ hcryptoinclude_HEADERS = \
ui.h \
undef.h
-install-build-headers:: $(hcryptoinclude_HEADERS)
+install-build-headers:: $(hcryptoinclude_HEADERS) $(x25519include_HEADERS)
@foo='$(hcryptoinclude_HEADERS)'; \
for f in $$foo; do \
f=`basename $$f`; \
@@ -95,6 +102,22 @@ SCRIPT_TESTS = \
noinst_PROGRAMS = test_rand
+noinst_HEADERS = \
+ x25519/ed25519_ref10_fe_51.h \
+ x25519/ed25519_ref10_fe_25_5.h \
+ x25519/ed25519_ref10.h \
+ x25519/fe_25_5/base.h \
+ x25519/fe_25_5/base2.h \
+ x25519/fe_25_5/constants.h \
+ x25519/fe_25_5/fe.h \
+ x25519/fe_51/base.h \
+ x25519/fe_51/base2.h \
+ x25519/fe_51/constants.h \
+ x25519/fe_51/fe.h \
+ x25519/align.h \
+ x25519_ref10.h
+
+
check_PROGRAMS = $(PROGRAM_TESTS) test_rsa test_dh example_evp_cipher
check_SCRIPTS = $(SCRIPT_TESTS)
@@ -105,6 +128,7 @@ test_rand_LDADD = $(LDADD) -lm
libhcrypto_la_SOURCES = \
$(ltmsources) \
+ $(x25519sources)\
aes.c \
aes.h \
bn.c \
@@ -168,131 +192,172 @@ libhcrypto_la_SOURCES = \
undef.h
ltmsources = \
- libtommath/tommath.h \
- libtommath/tommath_class.h \
- libtommath/tommath_superclass.h \
- libtommath/bncore.c \
- libtommath/bn_mp_init.c \
+ libtommath/bn_cutoffs.c \
+ libtommath/bn_deprecated.c \
+ libtommath/bn_mp_2expt.c \
+ libtommath/bn_mp_abs.c \
+ libtommath/bn_mp_add.c \
+ libtommath/bn_mp_add_d.c \
+ libtommath/bn_mp_addmod.c \
+ libtommath/bn_mp_and.c \
+ libtommath/bn_mp_clamp.c \
libtommath/bn_mp_clear.c \
+ libtommath/bn_mp_clear_multi.c \
+ libtommath/bn_mp_cmp.c \
+ libtommath/bn_mp_cmp_d.c \
+ libtommath/bn_mp_cmp_mag.c \
+ libtommath/bn_mp_cnt_lsb.c \
+ libtommath/bn_mp_complement.c \
+ libtommath/bn_mp_copy.c \
+ libtommath/bn_mp_count_bits.c \
+ libtommath/bn_mp_decr.c \
+ libtommath/bn_mp_div.c \
+ libtommath/bn_mp_div_2.c \
+ libtommath/bn_mp_div_2d.c \
+ libtommath/bn_mp_div_3.c \
+ libtommath/bn_mp_div_d.c \
+ libtommath/bn_mp_dr_is_modulus.c \
+ libtommath/bn_mp_dr_reduce.c \
+ libtommath/bn_mp_dr_setup.c \
+ libtommath/bn_mp_error_to_string.c \
libtommath/bn_mp_exch.c \
+ libtommath/bn_mp_expt_u32.c \
+ libtommath/bn_mp_exptmod.c \
+ libtommath/bn_mp_exteuclid.c \
+ libtommath/bn_mp_fread.c \
+ libtommath/bn_mp_from_sbin.c \
+ libtommath/bn_mp_from_ubin.c \
+ libtommath/bn_mp_fwrite.c \
+ libtommath/bn_mp_gcd.c \
+ libtommath/bn_mp_get_double.c \
+ libtommath/bn_mp_get_i32.c \
+ libtommath/bn_mp_get_i64.c \
+ libtommath/bn_mp_get_l.c \
+ libtommath/bn_mp_get_ll.c \
+ libtommath/bn_mp_get_mag_u32.c \
+ libtommath/bn_mp_get_mag_u64.c \
+ libtommath/bn_mp_get_mag_ul.c \
+ libtommath/bn_mp_get_mag_ull.c \
libtommath/bn_mp_grow.c \
- libtommath/bn_mp_shrink.c \
- libtommath/bn_mp_clamp.c \
- libtommath/bn_mp_zero.c \
- libtommath/bn_mp_zero_multi.c \
- libtommath/bn_mp_set.c \
- libtommath/bn_mp_set_int.c \
- libtommath/bn_mp_init_size.c \
- libtommath/bn_mp_copy.c \
+ libtommath/bn_mp_incr.c \
+ libtommath/bn_mp_init.c \
libtommath/bn_mp_init_copy.c \
- libtommath/bn_mp_abs.c \
- libtommath/bn_mp_neg.c \
- libtommath/bn_mp_cmp_mag.c \
- libtommath/bn_mp_cmp.c \
- libtommath/bn_mp_cmp_d.c \
- libtommath/bn_mp_rshd.c \
+ libtommath/bn_mp_init_i32.c \
+ libtommath/bn_mp_init_i64.c \
+ libtommath/bn_mp_init_l.c \
+ libtommath/bn_mp_init_ll.c \
+ libtommath/bn_mp_init_multi.c \
+ libtommath/bn_mp_init_set.c \
+ libtommath/bn_mp_init_size.c \
+ libtommath/bn_mp_init_u32.c \
+ libtommath/bn_mp_init_u64.c \
+ libtommath/bn_mp_init_ul.c \
+ libtommath/bn_mp_init_ull.c \
+ libtommath/bn_mp_invmod.c \
+ libtommath/bn_mp_is_square.c \
+ libtommath/bn_mp_iseven.c \
+ libtommath/bn_mp_isodd.c \
+ libtommath/bn_mp_kronecker.c \
+ libtommath/bn_mp_lcm.c \
+ libtommath/bn_mp_log_u32.c \
libtommath/bn_mp_lshd.c \
+ libtommath/bn_mp_mod.c \
libtommath/bn_mp_mod_2d.c \
- libtommath/bn_mp_div_2d.c \
- libtommath/bn_mp_mul_2d.c \
- libtommath/bn_mp_div_2.c \
- libtommath/bn_mp_mul_2.c \
- libtommath/bn_s_mp_add.c \
- libtommath/bn_s_mp_sub.c \
- libtommath/bn_fast_s_mp_mul_digs.c \
- libtommath/bn_s_mp_mul_digs.c \
- libtommath/bn_fast_s_mp_mul_high_digs.c \
- libtommath/bn_s_mp_mul_high_digs.c \
- libtommath/bn_fast_s_mp_sqr.c \
- libtommath/bn_s_mp_sqr.c \
- libtommath/bn_mp_add.c \
- libtommath/bn_mp_sub.c \
- libtommath/bn_mp_karatsuba_mul.c \
+ libtommath/bn_mp_mod_d.c \
+ libtommath/bn_mp_montgomery_calc_normalization.c \
+ libtommath/bn_mp_montgomery_reduce.c \
+ libtommath/bn_mp_montgomery_setup.c \
libtommath/bn_mp_mul.c \
- libtommath/bn_mp_karatsuba_sqr.c \
- libtommath/bn_mp_sqr.c \
- libtommath/bn_mp_div.c \
- libtommath/bn_mp_mod.c \
- libtommath/bn_mp_add_d.c \
- libtommath/bn_mp_sub_d.c \
+ libtommath/bn_mp_mul_2.c \
+ libtommath/bn_mp_mul_2d.c \
libtommath/bn_mp_mul_d.c \
- libtommath/bn_mp_div_d.c \
- libtommath/bn_mp_mod_d.c \
- libtommath/bn_mp_expt_d.c \
- libtommath/bn_mp_addmod.c \
- libtommath/bn_mp_submod.c \
libtommath/bn_mp_mulmod.c \
- libtommath/bn_mp_sqrmod.c \
- libtommath/bn_mp_gcd.c \
- libtommath/bn_mp_lcm.c \
- libtommath/bn_fast_mp_invmod.c \
- libtommath/bn_mp_invmod.c \
- libtommath/bn_mp_reduce.c \
- libtommath/bn_mp_montgomery_setup.c \
- libtommath/bn_fast_mp_montgomery_reduce.c \
- libtommath/bn_mp_montgomery_reduce.c \
- libtommath/bn_mp_exptmod_fast.c \
- libtommath/bn_mp_exptmod.c \
- libtommath/bn_mp_2expt.c \
- libtommath/bn_mp_n_root.c \
- libtommath/bn_mp_jacobi.c \
- libtommath/bn_reverse.c \
- libtommath/bn_mp_count_bits.c \
- libtommath/bn_mp_read_unsigned_bin.c \
- libtommath/bn_mp_read_signed_bin.c \
- libtommath/bn_mp_to_unsigned_bin.c \
- libtommath/bn_mp_to_signed_bin.c \
- libtommath/bn_mp_unsigned_bin_size.c \
- libtommath/bn_mp_signed_bin_size.c \
- libtommath/bn_mp_xor.c \
- libtommath/bn_mp_and.c \
+ libtommath/bn_mp_neg.c \
libtommath/bn_mp_or.c \
- libtommath/bn_mp_rand.c \
- libtommath/bn_mp_montgomery_calc_normalization.c \
- libtommath/bn_mp_prime_is_divisible.c \
- libtommath/bn_prime_tab.c \
+ libtommath/bn_mp_pack.c \
+ libtommath/bn_mp_pack_count.c \
libtommath/bn_mp_prime_fermat.c \
- libtommath/bn_mp_prime_miller_rabin.c \
+ libtommath/bn_mp_prime_frobenius_underwood.c \
libtommath/bn_mp_prime_is_prime.c \
+ libtommath/bn_mp_prime_miller_rabin.c \
libtommath/bn_mp_prime_next_prime.c \
- libtommath/bn_mp_find_prime.c \
- libtommath/bn_mp_dr_reduce.c \
- libtommath/bn_mp_dr_is_modulus.c \
- libtommath/bn_mp_dr_setup.c \
- libtommath/bn_mp_reduce_setup.c \
- libtommath/bn_mp_toom_mul.c \
- libtommath/bn_mp_toom_sqr.c \
- libtommath/bn_mp_div_3.c \
- libtommath/bn_s_mp_exptmod.c \
+ libtommath/bn_mp_prime_rabin_miller_trials.c \
+ libtommath/bn_mp_prime_rand.c \
+ libtommath/bn_mp_prime_strong_lucas_selfridge.c \
+ libtommath/bn_mp_radix_size.c \
+ libtommath/bn_mp_radix_smap.c \
+ libtommath/bn_mp_rand.c \
+ libtommath/bn_mp_read_radix.c \
+ libtommath/bn_mp_reduce.c \
libtommath/bn_mp_reduce_2k.c \
- libtommath/bn_mp_reduce_is_2k.c \
- libtommath/bn_mp_reduce_2k_setup.c \
libtommath/bn_mp_reduce_2k_l.c \
- libtommath/bn_mp_reduce_is_2k_l.c \
+ libtommath/bn_mp_reduce_2k_setup.c \
libtommath/bn_mp_reduce_2k_setup_l.c \
- libtommath/bn_mp_radix_smap.c \
- libtommath/bn_mp_read_radix.c \
- libtommath/bn_mp_toradix.c \
- libtommath/bn_mp_radix_size.c \
- libtommath/bn_mp_fread.c \
- libtommath/bn_mp_fwrite.c \
- libtommath/bn_mp_cnt_lsb.c \
- libtommath/bn_error.c \
- libtommath/bn_mp_init_multi.c \
- libtommath/bn_mp_clear_multi.c \
- libtommath/bn_mp_exteuclid.c \
- libtommath/bn_mp_toradix_n.c \
- libtommath/bn_mp_prime_random_ex.c \
- libtommath/bn_mp_get_int.c \
+ libtommath/bn_mp_reduce_is_2k.c \
+ libtommath/bn_mp_reduce_is_2k_l.c \
+ libtommath/bn_mp_reduce_setup.c \
+ libtommath/bn_mp_root_u32.c \
+ libtommath/bn_mp_rshd.c \
+ libtommath/bn_mp_sbin_size.c \
+ libtommath/bn_mp_set.c \
+ libtommath/bn_mp_set_double.c \
+ libtommath/bn_mp_set_i32.c \
+ libtommath/bn_mp_set_i64.c \
+ libtommath/bn_mp_set_l.c \
+ libtommath/bn_mp_set_ll.c \
+ libtommath/bn_mp_set_u32.c \
+ libtommath/bn_mp_set_u64.c \
+ libtommath/bn_mp_set_ul.c \
+ libtommath/bn_mp_set_ull.c \
+ libtommath/bn_mp_shrink.c \
+ libtommath/bn_mp_signed_rsh.c \
+ libtommath/bn_mp_sqr.c \
+ libtommath/bn_mp_sqrmod.c \
libtommath/bn_mp_sqrt.c \
- libtommath/bn_mp_is_square.c \
- libtommath/bn_mp_init_set.c \
- libtommath/bn_mp_init_set_int.c \
- libtommath/bn_mp_invmod_slow.c \
- libtommath/bn_mp_prime_rabin_miller_trials.c \
- libtommath/bn_mp_to_signed_bin_n.c \
- libtommath/bn_mp_to_unsigned_bin_n.c
+ libtommath/bn_mp_sqrtmod_prime.c \
+ libtommath/bn_mp_sub.c \
+ libtommath/bn_mp_sub_d.c \
+ libtommath/bn_mp_submod.c \
+ libtommath/bn_mp_to_radix.c \
+ libtommath/bn_mp_to_sbin.c \
+ libtommath/bn_mp_to_ubin.c \
+ libtommath/bn_mp_ubin_size.c \
+ libtommath/bn_mp_unpack.c \
+ libtommath/bn_mp_xor.c \
+ libtommath/bn_mp_zero.c \
+ libtommath/bn_prime_tab.c \
+ libtommath/bn_s_mp_add.c \
+ libtommath/bn_s_mp_balance_mul.c \
+ libtommath/bn_s_mp_exptmod.c \
+ libtommath/bn_s_mp_exptmod_fast.c \
+ libtommath/bn_s_mp_get_bit.c \
+ libtommath/bn_s_mp_invmod_fast.c \
+ libtommath/bn_s_mp_invmod_slow.c \
+ libtommath/bn_s_mp_karatsuba_mul.c \
+ libtommath/bn_s_mp_karatsuba_sqr.c \
+ libtommath/bn_s_mp_montgomery_reduce_fast.c \
+ libtommath/bn_s_mp_mul_digs.c \
+ libtommath/bn_s_mp_mul_digs_fast.c \
+ libtommath/bn_s_mp_mul_high_digs.c \
+ libtommath/bn_s_mp_mul_high_digs_fast.c \
+ libtommath/bn_s_mp_prime_is_divisible.c \
+ libtommath/bn_s_mp_rand_jenkins.c \
+ libtommath/bn_s_mp_rand_platform.c \
+ libtommath/bn_s_mp_reverse.c \
+ libtommath/bn_s_mp_sqr.c \
+ libtommath/bn_s_mp_sqr_fast.c \
+ libtommath/bn_s_mp_sub.c \
+ libtommath/bn_s_mp_toom_mul.c \
+ libtommath/bn_s_mp_toom_sqr.c \
+ libtommath/tommath_private.h \
+ libtommath/tommath_cutoffs.h \
+ libtommath/tommath_superclass.h \
+ libtommath/tommath_class.h \
+ libtommath/tommath.h
+x25519sources = \
+ x25519/ed25519_ref10.c \
+ x25519/x25519_ref10.c
$(libhcrypto_la_OBJECTS) $(test_rand_OBJECTS): hcrypto-link