aboutsummaryrefslogtreecommitdiff
path: root/lib/lsan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/lsan/CMakeLists.txt')
-rw-r--r--lib/lsan/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/lsan/CMakeLists.txt b/lib/lsan/CMakeLists.txt
index 73e475d2fdba..b782f2421dc2 100644
--- a/lib/lsan/CMakeLists.txt
+++ b/lib/lsan/CMakeLists.txt
@@ -23,9 +23,8 @@ add_compiler_rt_object_libraries(RTLSanCommon
CFLAGS ${LSAN_CFLAGS})
if(COMPILER_RT_HAS_LSAN)
+ add_compiler_rt_component(lsan)
foreach(arch ${LSAN_SUPPORTED_ARCH})
- add_compiler_rt_component(lsan)
-
add_compiler_rt_runtime(clang_rt.lsan
STATIC
ARCHS ${arch}