aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/expression_command/po_verbosity
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/expression_command/po_verbosity')
-rw-r--r--packages/Python/lldbsuite/test/expression_command/po_verbosity/Makefile6
-rw-r--r--packages/Python/lldbsuite/test/expression_command/po_verbosity/TestPoVerbosity.py61
-rw-r--r--packages/Python/lldbsuite/test/expression_command/po_verbosity/main.m9
3 files changed, 76 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/expression_command/po_verbosity/Makefile b/packages/Python/lldbsuite/test/expression_command/po_verbosity/Makefile
new file mode 100644
index 000000000000..4464e2ee9f5c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/po_verbosity/Makefile
@@ -0,0 +1,6 @@
+LEVEL = ../../make
+
+OBJC_SOURCES := main.m
+
+include $(LEVEL)/Makefile.rules
+LDFLAGS += -framework Cocoa
diff --git a/packages/Python/lldbsuite/test/expression_command/po_verbosity/TestPoVerbosity.py b/packages/Python/lldbsuite/test/expression_command/po_verbosity/TestPoVerbosity.py
new file mode 100644
index 000000000000..e415b92a43a6
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/po_verbosity/TestPoVerbosity.py
@@ -0,0 +1,61 @@
+"""
+Test that the po command acts correctly.
+"""
+
+from __future__ import print_function
+
+
+
+import lldb
+import lldbsuite.test.lldbutil as lldbutil
+from lldbsuite.test.lldbtest import *
+
+class PoVerbosityTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number to break for main.cpp.
+ self.line = line_number('main.m',
+ '// Stop here')
+
+ @skipUnlessDarwin
+ def test(self):
+ """Test that the po command acts correctly."""
+ self.build()
+
+ # This is the function to remove the custom formats in order to have a
+ # clean slate for the next test case.
+ def cleanup():
+ self.runCmd('type summary clear', check=False)
+ self.runCmd('type synthetic clear', check=False)
+
+ # Execute the cleanup function during test case tear down.
+ self.addTearDownHook(cleanup)
+
+ """Test expr + formatters for good interoperability."""
+ self.runCmd("file a.out", CURRENT_EXECUTABLE_SET)
+
+ lldbutil.run_break_set_by_file_and_line (self, "main.m", self.line, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ self.expect("expr -O -v -- foo",
+ substrs = ['(id) $',' = 0x', '1 = 2','2 = 3;'])
+ self.expect("expr -O -vfull -- foo",
+ substrs = ['(id) $',' = 0x', '1 = 2','2 = 3;'])
+ self.expect("expr -O -- foo",matching=False,
+ substrs = ['(id) $'])
+
+ self.expect("expr -O -- 22",matching=False,
+ substrs = ['(int) $'])
+ self.expect("expr -O -- 22",
+ substrs = ['22'])
+
+ self.expect("expr -O -vfull -- 22",
+ substrs = ['(int) $', ' = 22'])
+
+ self.expect("expr -O -v -- 22",
+ substrs = ['(int) $', ' = 22'])
diff --git a/packages/Python/lldbsuite/test/expression_command/po_verbosity/main.m b/packages/Python/lldbsuite/test/expression_command/po_verbosity/main.m
new file mode 100644
index 000000000000..3dbb024b2809
--- /dev/null
+++ b/packages/Python/lldbsuite/test/expression_command/po_verbosity/main.m
@@ -0,0 +1,9 @@
+#import <Cocoa/Cocoa.h>
+
+int main()
+{
+ [NSString initialize];
+ id foo = @{@1 : @2, @2 : @3};
+ int x = 34;
+ return 0; // Stop here
+}