aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile b/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
new file mode 100644
index 000000000000..c60ecd414635
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
@@ -0,0 +1,18 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+
+ifeq "$(OS)" ""
+ OS = $(shell uname -s)
+endif
+
+ifeq "$(OS)" "Darwin"
+ LDFLAGS = $(CFLAGS) -Xlinker -dead_strip
+else
+ CFLAGS += -fdata-sections -ffunction-sections
+ LDFLAGS = $(CFLAGS) -Wl,--gc-sections
+endif
+
+MAKE_DSYM := NO
+
+include $(LEVEL)/Makefile.rules