aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/functionalities/disassembly
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/disassembly')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/disassembly/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/disassembly/TestDisassembleBreakpoint.py54
-rw-r--r--packages/Python/lldbsuite/test/functionalities/disassembly/main.cpp28
3 files changed, 87 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/disassembly/Makefile b/packages/Python/lldbsuite/test/functionalities/disassembly/Makefile
new file mode 100644
index 000000000000..8a7102e347af
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/disassembly/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/disassembly/TestDisassembleBreakpoint.py b/packages/Python/lldbsuite/test/functionalities/disassembly/TestDisassembleBreakpoint.py
new file mode 100644
index 000000000000..df2308de7605
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/disassembly/TestDisassembleBreakpoint.py
@@ -0,0 +1,54 @@
+"""
+Test some lldb command abbreviations.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class DisassemblyTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @expectedFailureWindows # Function name prints fully demangled instead of name-only
+ def test(self):
+ self.build()
+ exe = os.path.join (os.getcwd(), "a.out")
+ self.expect("file " + exe,
+ patterns = [ "Current executable set to .*a.out.*" ])
+
+ match_object = lldbutil.run_break_set_command (self, "br s -n sum")
+ lldbutil.check_breakpoint_result (self, match_object, symbol_name='sum', symbol_match_exact=False, num_locations=1)
+
+ self.expect("run",
+ patterns = [ "Process .* launched: "])
+
+ self.runCmd("dis -f")
+ disassembly = self.res.GetOutput()
+
+ # ARCH, if not specified, defaults to x86_64.
+ arch = self.getArchitecture()
+ if arch in ["", 'x86_64', 'i386', 'i686']:
+ breakpoint_opcodes = ["int3"]
+ instructions = [' mov', ' addl ', 'ret']
+ elif arch in ["arm", "aarch64"]:
+ breakpoint_opcodes = ["brk", "udf"]
+ instructions = [' add ', ' ldr ', ' str ']
+ elif re.match("mips" , arch):
+ breakpoint_opcodes = ["break"]
+ instructions = ['lw', 'sw', 'jr']
+ else:
+ # TODO please add your arch here
+ self.fail('unimplemented for arch = "{arch}"'.format(arch=self.getArchitecture()))
+
+ # make sure that the software breakpoint has been removed
+ for op in breakpoint_opcodes:
+ self.assertFalse(op in disassembly)
+
+ # make sure a few reasonable assembly instructions are here
+ self.expect(disassembly, exe=False, startstr = "a.out`sum", substrs = instructions)
diff --git a/packages/Python/lldbsuite/test/functionalities/disassembly/main.cpp b/packages/Python/lldbsuite/test/functionalities/disassembly/main.cpp
new file mode 100644
index 000000000000..8813647f6b72
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/disassembly/main.cpp
@@ -0,0 +1,28 @@
+//===-- main.cpp ------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+int
+sum (int a, int b)
+{
+ int result = a + b;
+ return result;
+}
+
+int
+main(int argc, char const *argv[])
+{
+
+ int array[3];
+
+ array[0] = sum (1238, 78392);
+ array[1] = sum (379265, 23674);
+ array[2] = sum (872934, 234);
+
+ return 0;
+}