aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/functionalities/fat_archives/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/fat_archives/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/fat_archives/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/fat_archives/Makefile b/packages/Python/lldbsuite/test/functionalities/fat_archives/Makefile
new file mode 100644
index 000000000000..e1832fdefbee
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/fat_archives/Makefile
@@ -0,0 +1,14 @@
+all: clean
+ $(CC) -arch i386 -g -c a.c
+ ar -q liba-i386.a a.o
+ ranlib liba-i386.a
+ $(CC) -arch x86_64 -g -c a.c
+ ar -q liba-x86_64.a a.o
+ ranlib liba-x86_64.a
+ lipo -create -output liba.a liba-i386.a liba-x86_64.a
+ $(CC) -g -c main.c
+ $(CC) -o a.out main.o -L. -la
+
+clean:
+ rm -rf a.o a.out liba-i386.a liba-x86_64.a liba.a $(wildcard *un~ .*un~ main.o *.pyc)
+