aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/functionalities/inferior-changed
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/inferior-changed')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/inferior-changed/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/functionalities/inferior-changed/TestInferiorChanged.py80
-rw-r--r--packages/Python/lldbsuite/test/functionalities/inferior-changed/main.c16
-rw-r--r--packages/Python/lldbsuite/test/functionalities/inferior-changed/main2.c18
4 files changed, 119 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/inferior-changed/Makefile b/packages/Python/lldbsuite/test/functionalities/inferior-changed/Makefile
new file mode 100644
index 000000000000..0d70f2595019
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/inferior-changed/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/inferior-changed/TestInferiorChanged.py b/packages/Python/lldbsuite/test/functionalities/inferior-changed/TestInferiorChanged.py
new file mode 100644
index 000000000000..830c7f69355f
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/inferior-changed/TestInferiorChanged.py
@@ -0,0 +1,80 @@
+"""Test lldb reloads the inferior after it was changed during the session."""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test import configuration
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class ChangedInferiorTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @skipIfHostWindows
+ def test_inferior_crashing(self):
+ """Test lldb reloads the inferior after it was changed during the session."""
+ self.build()
+ self.inferior_crashing()
+ self.cleanup()
+ # lldb needs to recognize the inferior has changed. If lldb needs to check the
+ # new module timestamp, make sure it is not the same as the old one, so add a
+ # 1 second delay.
+ time.sleep(1)
+ d = {'C_SOURCES': 'main2.c'}
+ self.build(dictionary=d)
+ self.setTearDownCleanup(dictionary=d)
+ self.inferior_not_crashing()
+
+ def setUp(self):
+ # Call super's setUp().
+ TestBase.setUp(self)
+ # Find the line number of the crash.
+ self.line1 = line_number('main.c', '// Crash here.')
+ self.line2 = line_number('main2.c', '// Not crash here.')
+
+ def inferior_crashing(self):
+ """Inferior crashes upon launching; lldb should catch the event and stop."""
+ self.exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + self.exe, CURRENT_EXECUTABLE_SET)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # We should have one crashing thread
+ self.assertEqual(
+ len(lldbutil.get_crashed_threads(self, self.dbg.GetSelectedTarget().GetProcess())),
+ 1,
+ STOPPED_DUE_TO_EXC_BAD_ACCESS)
+
+ # And it should report the correct line number.
+ self.expect("thread backtrace all", substrs = ['main.c:%d' % self.line1])
+
+ def inferior_not_crashing(self):
+ """Test lldb reloads the inferior after it was changed during the session."""
+ self.runCmd("process kill")
+ self.runCmd("run", RUN_SUCCEEDED)
+ self.runCmd("process status")
+
+ self.assertNotEqual(
+ len(lldbutil.get_crashed_threads(self, self.dbg.GetSelectedTarget().GetProcess())),
+ 1,
+ "Inferior changed, but lldb did not perform a reload")
+
+ # Break inside the main.
+ lldbutil.run_break_set_by_file_and_line (self, "main2.c", self.line2, num_expected_locations=1, loc_exact=True)
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ self.runCmd("frame variable int_ptr")
+ self.expect("frame variable *int_ptr",
+ substrs = ['= 7'])
+ self.expect("expression *int_ptr",
+ substrs = ['= 7'])
diff --git a/packages/Python/lldbsuite/test/functionalities/inferior-changed/main.c b/packages/Python/lldbsuite/test/functionalities/inferior-changed/main.c
new file mode 100644
index 000000000000..9d0706a0862d
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/inferior-changed/main.c
@@ -0,0 +1,16 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+
+int main(int argc, const char* argv[])
+{
+ int *null_ptr = 0;
+ printf("Hello, segfault!\n");
+ printf("Now crash %d\n", *null_ptr); // Crash here.
+}
diff --git a/packages/Python/lldbsuite/test/functionalities/inferior-changed/main2.c b/packages/Python/lldbsuite/test/functionalities/inferior-changed/main2.c
new file mode 100644
index 000000000000..9173e8c30b59
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/inferior-changed/main2.c
@@ -0,0 +1,18 @@
+//===-- main2.c -------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <stdlib.h>
+
+int main(int argc, const char* argv[])
+{
+ int *int_ptr = (int *)malloc(sizeof(int));
+ *int_ptr = 7;
+ printf("Hello, world!\n");
+ printf("Now not crash %d\n", *int_ptr); // Not crash here.
+}