aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/load_unload/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/load_unload/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile b/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile
new file mode 100644
index 000000000000..779745c4d26c
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/load_unload/Makefile
@@ -0,0 +1,24 @@
+LEVEL := ../../make
+
+LIB_PREFIX := loadunload_
+
+LD_EXTRAS := -L. -l$(LIB_PREFIX)d -ldl
+CXX_SOURCES := main.cpp
+
+include $(LEVEL)/Makefile.rules
+
+.PHONY:
+a.out: lib_a lib_b lib_c lib_d hidden_lib_d
+
+lib_%:
+ $(MAKE) -f $*.mk
+
+hidden_lib_d:
+ $(MAKE) -C hidden
+
+clean::
+ $(MAKE) -f a.mk clean
+ $(MAKE) -f b.mk clean
+ $(MAKE) -f c.mk clean
+ $(MAKE) -f d.mk clean
+ $(MAKE) -C hidden clean