aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/functionalities/plugins/commands
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/functionalities/plugins/commands')
-rw-r--r--packages/Python/lldbsuite/test/functionalities/plugins/commands/Makefile8
-rw-r--r--packages/Python/lldbsuite/test/functionalities/plugins/commands/TestPluginCommands.py58
-rw-r--r--packages/Python/lldbsuite/test/functionalities/plugins/commands/plugin.cpp62
3 files changed, 128 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/functionalities/plugins/commands/Makefile b/packages/Python/lldbsuite/test/functionalities/plugins/commands/Makefile
new file mode 100644
index 000000000000..8af06446ecef
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/plugins/commands/Makefile
@@ -0,0 +1,8 @@
+LEVEL = ../../../make
+
+DYLIB_CXX_SOURCES := plugin.cpp
+DYLIB_NAME := plugin
+DYLIB_ONLY := YES
+MAKE_DSYM := NO
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/functionalities/plugins/commands/TestPluginCommands.py b/packages/Python/lldbsuite/test/functionalities/plugins/commands/TestPluginCommands.py
new file mode 100644
index 000000000000..b62c30bcf4e7
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/plugins/commands/TestPluginCommands.py
@@ -0,0 +1,58 @@
+"""
+Test that plugins that load commands work correctly.
+"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import re
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class PluginCommandTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @skipIfNoSBHeaders
+ @skipIfHostIncompatibleWithRemote # Requires a compatible arch and platform to link against the host's built lldb lib.
+ @expectedFailureWindows("llvm.org/pr24778")
+ @no_debug_info_test
+ def test_load_plugin(self):
+ """Test that plugins that load commands work correctly."""
+
+ plugin_name = "plugin"
+ if sys.platform.startswith("darwin"):
+ plugin_lib_name = "lib%s.dylib" % plugin_name
+ else:
+ plugin_lib_name = "lib%s.so" % plugin_name
+
+ # Invoke the library build rule.
+ self.buildLibrary("plugin.cpp", plugin_name)
+
+ debugger = lldb.SBDebugger.Create()
+
+ retobj = lldb.SBCommandReturnObject()
+
+ retval = debugger.GetCommandInterpreter().HandleCommand("plugin load %s" % plugin_lib_name, retobj)
+
+ retobj.Clear()
+
+ retval = debugger.GetCommandInterpreter().HandleCommand("plugin_loaded_command child abc def ghi",retobj)
+
+ if self.TraceOn():
+ print(retobj.GetOutput())
+
+ self.expect(retobj,substrs = ['abc def ghi'], exe=False)
+
+ retobj.Clear()
+
+ # check that abbreviations work correctly in plugin commands.
+ retval = debugger.GetCommandInterpreter().HandleCommand("plugin_loaded_ ch abc def ghi",retobj)
+
+ if self.TraceOn():
+ print(retobj.GetOutput())
+
+ self.expect(retobj,substrs = ['abc def ghi'], exe=False)
diff --git a/packages/Python/lldbsuite/test/functionalities/plugins/commands/plugin.cpp b/packages/Python/lldbsuite/test/functionalities/plugins/commands/plugin.cpp
new file mode 100644
index 000000000000..be3d29325de1
--- /dev/null
+++ b/packages/Python/lldbsuite/test/functionalities/plugins/commands/plugin.cpp
@@ -0,0 +1,62 @@
+//===-- plugin.cpp -------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+
+/*
+An example plugin for LLDB that provides a new foo command with a child subcommand
+Compile this into a dylib foo.dylib and load by placing in appropriate locations on disk or
+by typing plugin load foo.dylib at the LLDB command line
+*/
+
+#if defined (__APPLE__)
+#include <LLDB/SBCommandInterpreter.h>
+#include <LLDB/SBCommandReturnObject.h>
+#include <LLDB/SBDebugger.h>
+#else
+#include <lldb/API/SBCommandInterpreter.h>
+#include <lldb/API/SBCommandReturnObject.h>
+#include <lldb/API/SBDebugger.h>
+#endif
+
+namespace lldb {
+ bool
+ PluginInitialize (lldb::SBDebugger debugger);
+}
+
+class ChildCommand : public lldb::SBCommandPluginInterface
+{
+public:
+ virtual bool
+ DoExecute (lldb::SBDebugger debugger,
+ char** command,
+ lldb::SBCommandReturnObject &result)
+ {
+ if (command)
+ {
+ const char* arg = *command;
+ while (arg)
+ {
+ result.Printf("%s ",arg);
+ arg = *(++command);
+ }
+ result.Printf("\n");
+ return true;
+ }
+ return false;
+ }
+
+};
+
+bool
+lldb::PluginInitialize (lldb::SBDebugger debugger)
+{
+ lldb::SBCommandInterpreter interpreter = debugger.GetCommandInterpreter();
+ lldb::SBCommand foo = interpreter.AddMultiwordCommand("plugin_loaded_command",NULL);
+ foo.AddCommand("child",new ChildCommand(),"a child of plugin_loaded_command");
+ return true;
+}