aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/lang/c/register_variables
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/lang/c/register_variables')
-rw-r--r--packages/Python/lldbsuite/test/lang/c/register_variables/Makefile7
-rw-r--r--packages/Python/lldbsuite/test/lang/c/register_variables/TestRegisterVariables.py70
-rw-r--r--packages/Python/lldbsuite/test/lang/c/register_variables/test.c27
3 files changed, 104 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/c/register_variables/Makefile b/packages/Python/lldbsuite/test/lang/c/register_variables/Makefile
new file mode 100644
index 000000000000..12e55616b540
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/register_variables/Makefile
@@ -0,0 +1,7 @@
+LEVEL = ../../../make
+
+C_SOURCES := test.c
+
+CFLAGS ?= -g -O1
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/lang/c/register_variables/TestRegisterVariables.py b/packages/Python/lldbsuite/test/lang/c/register_variables/TestRegisterVariables.py
new file mode 100644
index 000000000000..7ef1f246bfd3
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/register_variables/TestRegisterVariables.py
@@ -0,0 +1,70 @@
+"""Check that compiler-generated register values work correctly"""
+
+from __future__ import print_function
+
+
+
+import os, time
+import lldb
+from lldbsuite.test.lldbtest import *
+import lldbsuite.test.lldbutil as lldbutil
+
+class RegisterVariableTestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @expectedFailureAll(oslist=['macosx'], compiler='clang', compiler_version=['<', '7.0.0'], debug_info="dsym")
+ @expectedFailureClang(None, ['<', '3.5'])
+ @expectedFailureGcc(None, ['is', '4.8.2'])
+ def test_and_run_command(self):
+ """Test expressions on register values."""
+ self.build()
+ exe = os.path.join(os.getcwd(), "a.out")
+ self.runCmd("file " + exe, CURRENT_EXECUTABLE_SET)
+
+ # Break inside the main.
+ lldbutil.run_break_set_by_source_regexp(self, "break", num_expected_locations=2)
+
+ ####################
+ # First breakpoint
+
+ self.runCmd("run", RUN_SUCCEEDED)
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # The breakpoint should have a hit count of 1.
+ self.expect("breakpoint list -f", BREAKPOINT_HIT_ONCE,
+ substrs = [' resolved, hit count = 1'])
+
+ # Try some variables that should be visible
+ self.expect("expr a", VARIABLES_DISPLAYED_CORRECTLY,
+ substrs = ['(int) $0 = 2'])
+
+ self.expect("expr b->m1", VARIABLES_DISPLAYED_CORRECTLY,
+ substrs = ['(int) $1 = 3'])
+
+ #####################
+ # Second breakpoint
+
+ self.runCmd("continue")
+
+ # The stop reason of the thread should be breakpoint.
+ self.expect("thread list", STOPPED_DUE_TO_BREAKPOINT,
+ substrs = ['stopped',
+ 'stop reason = breakpoint'])
+
+ # The breakpoint should have a hit count of 1.
+ self.expect("breakpoint list -f", BREAKPOINT_HIT_ONCE,
+ substrs = [' resolved, hit count = 1'])
+
+ # Try some variables that should be visible
+ self.expect("expr b->m2", VARIABLES_DISPLAYED_CORRECTLY,
+ substrs = ['(int) $2 = 5'])
+
+ self.expect("expr c", VARIABLES_DISPLAYED_CORRECTLY,
+ substrs = ['(int) $3 = 5'])
+
+ self.runCmd("kill")
diff --git a/packages/Python/lldbsuite/test/lang/c/register_variables/test.c b/packages/Python/lldbsuite/test/lang/c/register_variables/test.c
new file mode 100644
index 000000000000..e467ac48f745
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/register_variables/test.c
@@ -0,0 +1,27 @@
+#include <stdio.h>
+
+struct bar {
+ int m1;
+ int m2;
+};
+
+void f1(int a, struct bar *b) __attribute__ ((noinline));
+void f1(int a, struct bar *b)
+{
+ b->m2 = b->m1 + a; // set breakpoint here
+}
+
+void f2(struct bar *b) __attribute__ ((noinline));
+void f2(struct bar *b)
+{
+ int c = b->m2;
+ printf("%d\n", c); // set breakpoint here
+}
+
+int main()
+{
+ struct bar myBar = { 3, 4 };
+ f1(2, &myBar);
+ f2(&myBar);
+ return 0;
+}