aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/lang/c/shared_lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/lang/c/shared_lib/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/lang/c/shared_lib/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/lang/c/shared_lib/Makefile b/packages/Python/lldbsuite/test/lang/c/shared_lib/Makefile
new file mode 100644
index 000000000000..854002e64708
--- /dev/null
+++ b/packages/Python/lldbsuite/test/lang/c/shared_lib/Makefile
@@ -0,0 +1,8 @@
+LEVEL = ../../../make
+
+DYLIB_NAME := foo
+DYLIB_C_SOURCES := foo.c
+C_SOURCES := main.c
+CFLAGS_EXTRAS += -fPIC
+
+include $(LEVEL)/Makefile.rules