aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/macosx/thread-names/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/macosx/thread-names/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/macosx/thread-names/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/macosx/thread-names/Makefile b/packages/Python/lldbsuite/test/macosx/thread-names/Makefile
new file mode 100644
index 000000000000..93f2f7b2f340
--- /dev/null
+++ b/packages/Python/lldbsuite/test/macosx/thread-names/Makefile
@@ -0,0 +1,28 @@
+CC ?= clang
+ifeq "$(ARCH)" ""
+ ARCH = x86_64
+endif
+
+ifeq "$(OS)" ""
+ OS = $(shell uname -s)
+endif
+
+CFLAGS ?= -g -O0
+CWD := $(shell pwd)
+
+LIB_PREFIX := lib
+
+ifeq "$(OS)" "Darwin"
+ CFLAGS += -arch $(ARCH)
+endif
+
+all: a.out
+
+a.out: main.o
+ $(CC) $(CFLAGS) -o a.out main.o
+
+main.o: main.c
+ $(CC) $(CFLAGS) -c main.c
+
+clean:
+ rm -rf $(wildcard *.o *~ *.dylib *.so a.out *.dSYM)