aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/macosx/universal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/macosx/universal/Makefile')
-rw-r--r--packages/Python/lldbsuite/test/macosx/universal/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/macosx/universal/Makefile b/packages/Python/lldbsuite/test/macosx/universal/Makefile
new file mode 100644
index 000000000000..854c78ed8c29
--- /dev/null
+++ b/packages/Python/lldbsuite/test/macosx/universal/Makefile
@@ -0,0 +1,19 @@
+CC ?= clang
+
+testit: testit.i386 testit.x86_64
+ lipo -create -o testit testit.i386 testit.x86_64
+
+testit.i386: testit.i386.o
+ $(CC) -arch i386 -o testit.i386 testit.i386.o
+
+testit.x86_64: testit.x86_64.o
+ $(CC) -arch x86_64 -o testit.x86_64 testit.x86_64.o
+
+testit.i386.o: main.c
+ $(CC) -g -O0 -arch i386 -c -o testit.i386.o main.c
+
+testit.x86_64.o: main.c
+ $(CC) -g -O0 -arch x86_64 -c -o testit.x86_64.o main.c
+
+clean:
+ rm -rf $(wildcard testit* *~)