aboutsummaryrefslogtreecommitdiff
path: root/packages/Python/lldbsuite/test/python_api/section
diff options
context:
space:
mode:
Diffstat (limited to 'packages/Python/lldbsuite/test/python_api/section')
-rw-r--r--packages/Python/lldbsuite/test/python_api/section/Makefile5
-rw-r--r--packages/Python/lldbsuite/test/python_api/section/TestSectionAPI.py41
-rw-r--r--packages/Python/lldbsuite/test/python_api/section/main.c28
3 files changed, 74 insertions, 0 deletions
diff --git a/packages/Python/lldbsuite/test/python_api/section/Makefile b/packages/Python/lldbsuite/test/python_api/section/Makefile
new file mode 100644
index 000000000000..0d70f2595019
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/section/Makefile
@@ -0,0 +1,5 @@
+LEVEL = ../../make
+
+C_SOURCES := main.c
+
+include $(LEVEL)/Makefile.rules
diff --git a/packages/Python/lldbsuite/test/python_api/section/TestSectionAPI.py b/packages/Python/lldbsuite/test/python_api/section/TestSectionAPI.py
new file mode 100644
index 000000000000..587216468f06
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/section/TestSectionAPI.py
@@ -0,0 +1,41 @@
+"""
+Test SBSection APIs.
+"""
+
+from __future__ import print_function
+
+
+
+from lldbsuite.test.lldbtest import *
+
+class SectionAPITestCase(TestBase):
+
+ mydir = TestBase.compute_mydir(__file__)
+
+ @add_test_categories(['pyapi'])
+ def test_get_target_byte_size(self):
+ d = {'EXE': 'b.out'}
+ self.build(dictionary=d)
+ self.setTearDownCleanup(dictionary=d)
+ exe = os.path.join(os.getcwd(), 'b.out')
+ target = self.dbg.CreateTarget(exe)
+ self.assertTrue(target, VALID_TARGET)
+
+ # find the .data section of the main module
+ mod = target.GetModuleAtIndex(0)
+ data_section = None
+ for s in mod.sections:
+ sect_type = s.GetSectionType()
+ if sect_type == lldb.eSectionTypeData:
+ data_section = s
+ break
+ elif sect_type == lldb.eSectionTypeContainer:
+ for i in range(s.GetNumSubSections()):
+ ss = s.GetSubSectionAtIndex(i)
+ sect_type = ss.GetSectionType()
+ if sect_type == lldb.eSectionTypeData:
+ data_section = ss
+ break
+
+ self.assertIsNotNone(data_section)
+ self.assertEqual(data_section.target_byte_size, 1)
diff --git a/packages/Python/lldbsuite/test/python_api/section/main.c b/packages/Python/lldbsuite/test/python_api/section/main.c
new file mode 100644
index 000000000000..746681d721a9
--- /dev/null
+++ b/packages/Python/lldbsuite/test/python_api/section/main.c
@@ -0,0 +1,28 @@
+//===-- main.c --------------------------------------------------*- C++ -*-===//
+//
+// The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+#include <stdio.h>
+#include <string.h>
+
+// This simple program is to test the lldb Python API SBSection. It includes
+// somes global data, and so the build process produces a DATA section, which
+// the test code can use to query for the target byte size
+
+char my_global_var_of_char_type = 'X';
+
+int main (int argc, char const *argv[])
+{
+ // this code just "does something" with the global so that it is not
+ // optimised away
+ if (argc > 1 && strlen(argv[1]))
+ {
+ my_global_var_of_char_type += argv[1][0];
+ }
+
+ return my_global_var_of_char_type;
+}