aboutsummaryrefslogtreecommitdiff
path: root/projects/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'projects/CMakeLists.txt')
-rw-r--r--projects/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/projects/CMakeLists.txt b/projects/CMakeLists.txt
index dac637335bd1..36751cd31dac 100644
--- a/projects/CMakeLists.txt
+++ b/projects/CMakeLists.txt
@@ -10,3 +10,10 @@ foreach(entry ${entries})
endif()
endif()
endforeach(entry)
+
+# Also add in the compiler-rt tree if present and we have a sufficiently
+# recent version of CMake.
+if(${CMAKE_VERSION} VERSION_GREATER 2.8.7 AND
+ ${LLVM_BUILD_RUNTIME})
+ add_llvm_external_project(compiler-rt)
+endif()