aboutsummaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am44
1 files changed, 39 insertions, 5 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 76d765505bf2..017ea0219127 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,5 +1,39 @@
-bin_SCRIPTS= ntp-wait ntptrace
-noinst_SCRIPTS= calc_tickadj checktime freq_adj html2man mkver ntpsweep ntpver plot_summary summary
-EXTRA_DIST = VersionName fixautomakedepsmagic genCommitLog genver \
- hpadjtime.sh monitoring ntp-close ntp-groper ntp-restart \
- ntp-status rc1 rc2 stats
+NULL=
+
+if NTP_BINSUBDIR_IS_BIN
+bin_SCRIPTS = ntp-wait ntptrace
+else
+sbin_SCRIPTS = ntp-wait ntptrace
+endif
+
+noinst_SCRIPTS = \
+ calc_tickadj \
+ checktime \
+ freq_adj \
+ html2man \
+ mkver \
+ ntpsweep \
+ ntpver \
+ plot_summary \
+ summary \
+ $(NULL)
+
+EXTRA_DIST = \
+ check--help \
+ checkChangeLog \
+ cvo.sh \
+ fixautomakedepsmagic \
+ genCommitLog \
+ genver \
+ hpadjtime.sh \
+ monitoring \
+ ntp-close \
+ ntp-groper \
+ ntp-restart \
+ ntp-status \
+ rc1 \
+ rc2 \
+ stats \
+ UpdatePoint \
+ VersionName \
+ $(NULL)