aboutsummaryrefslogtreecommitdiff
path: root/sntp/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sntp/tests/Makefile.am')
-rw-r--r--sntp/tests/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sntp/tests/Makefile.am b/sntp/tests/Makefile.am
index c5338c791816..0e14a87b176e 100644
--- a/sntp/tests/Makefile.am
+++ b/sntp/tests/Makefile.am
@@ -34,8 +34,6 @@ run_unity = cd $(srcdir) && ruby ../unity/auto/generate_test_runner.rb
check_PROGRAMS = \
test-crypto \
test-keyFile \
- test-kodDatabase \
- test-kodFile \
test-log \
test-networking \
test-packetHandling \
@@ -43,6 +41,14 @@ check_PROGRAMS = \
test-utilities \
$(NULL)
+if BUILD_TEST_KODDATABASE
+check_PROGRAMS += test-kodDatabase
+endif
+
+if BUILD_TEST_KODFILE
+check_PROGRAMS += test-kodFile
+endif
+
noinst_HEADERS = \
sntptest.h \
$(NULL)