aboutsummaryrefslogtreecommitdiff
path: root/source/Host/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/Host/CMakeLists.txt')
-rw-r--r--source/Host/CMakeLists.txt43
1 files changed, 9 insertions, 34 deletions
diff --git a/source/Host/CMakeLists.txt b/source/Host/CMakeLists.txt
index 776fcfb44ffa..0e4a8a533e5f 100644
--- a/source/Host/CMakeLists.txt
+++ b/source/Host/CMakeLists.txt
@@ -4,7 +4,6 @@ macro(add_host_subdirectory group)
endmacro()
add_host_subdirectory(common
- common/Condition.cpp
common/File.cpp
common/FileCache.cpp
common/FileSpec.cpp
@@ -17,7 +16,6 @@ add_host_subdirectory(common
common/HostThread.cpp
common/IOObject.cpp
common/LockFileBase.cpp
- common/Mutex.cpp
common/MonitoringProcessLauncher.cpp
common/NativeBreakpoint.cpp
common/NativeBreakpointList.cpp
@@ -38,7 +36,6 @@ add_host_subdirectory(common
common/Terminal.cpp
common/ThisThread.cpp
common/ThreadLauncher.cpp
- common/TimeValue.cpp
common/XML.cpp
common/UDPSocket.cpp
)
@@ -60,7 +57,6 @@ add_host_subdirectory(posix
if (CMAKE_SYSTEM_NAME MATCHES "Windows")
add_host_subdirectory(windows
- windows/Condition.cpp
windows/ConnectionGenericFileWindows.cpp
windows/EditLineWin.cpp
windows/FileSystem.cpp
@@ -69,7 +65,6 @@ if (CMAKE_SYSTEM_NAME MATCHES "Windows")
windows/HostProcessWindows.cpp
windows/HostThreadWindows.cpp
windows/LockFileWindows.cpp
- windows/Mutex.cpp
windows/PipeWindows.cpp
windows/ProcessLauncherWindows.cpp
windows/ProcessRunLock.cpp
@@ -120,24 +115,17 @@ else()
add_host_subdirectory(android
android/HostInfoAndroid.cpp
android/LibcGlue.cpp
- android/ProcessLauncherAndroid.cpp
- linux/AbstractSocket.cpp
- linux/Host.cpp
- linux/HostInfoLinux.cpp
- linux/HostThreadLinux.cpp
- linux/LibcGlue.cpp
- linux/ThisThread.cpp
- )
- else()
- add_host_subdirectory(linux
- linux/AbstractSocket.cpp
- linux/Host.cpp
- linux/HostInfoLinux.cpp
- linux/HostThreadLinux.cpp
- linux/LibcGlue.cpp
- linux/ThisThread.cpp
)
endif()
+ add_host_subdirectory(linux
+ linux/AbstractSocket.cpp
+ linux/Host.cpp
+ linux/HostInfoLinux.cpp
+ linux/HostThreadLinux.cpp
+ linux/LibcGlue.cpp
+ linux/ProcessLauncherLinux.cpp
+ linux/ThisThread.cpp
+ )
elseif (CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
add_host_subdirectory(freebsd
@@ -170,19 +158,6 @@ if (${get_python_libdir})
endif()
endif()
-if (${get_python_libdir})
- # Call a python script to gather the arch-specific libdir for
- # modules like the lldb module.
- execute_process(
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/get_relative_lib_dir.py
- RESULT_VARIABLE get_libdir_status
- OUTPUT_VARIABLE relative_libdir
- )
- if (get_libdir_status EQUAL 0)
- add_definitions(-DLLDB_PYTHON_RELATIVE_LIBDIR="${relative_libdir}")
- endif()
-endif()
-
add_lldb_library(lldbHost ${HOST_SOURCES})
if (CMAKE_SYSTEM_NAME MATCHES "NetBSD")