aboutsummaryrefslogtreecommitdiff
path: root/source/Plugins/Instruction/MIPS64/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/Plugins/Instruction/MIPS64/CMakeLists.txt')
-rw-r--r--source/Plugins/Instruction/MIPS64/CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/source/Plugins/Instruction/MIPS64/CMakeLists.txt b/source/Plugins/Instruction/MIPS64/CMakeLists.txt
index 25c919c4edb6..ddb964bf50a5 100644
--- a/source/Plugins/Instruction/MIPS64/CMakeLists.txt
+++ b/source/Plugins/Instruction/MIPS64/CMakeLists.txt
@@ -1,3 +1,18 @@
-add_lldb_library(lldbPluginInstructionMIPS64
+if(Mips IN_LIST LLVM_TARGETS_TO_BUILD)
+ set(mips_target Mips)
+endif()
+
+add_lldb_library(lldbPluginInstructionMIPS64 PLUGIN
EmulateInstructionMIPS64.cpp
+
+ LINK_LIBS
+ lldbCore
+ lldbHost
+ lldbInterpreter
+ lldbSymbol
+ lldbPluginProcessUtility
+ LINK_COMPONENTS
+ MC
+ Support
+ ${mips_target}
)