aboutsummaryrefslogtreecommitdiff
path: root/source/Plugins/Process/Utility/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/Plugins/Process/Utility/CMakeLists.txt')
-rw-r--r--source/Plugins/Process/Utility/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/source/Plugins/Process/Utility/CMakeLists.txt b/source/Plugins/Process/Utility/CMakeLists.txt
new file mode 100644
index 000000000000..4a847b4f966a
--- /dev/null
+++ b/source/Plugins/Process/Utility/CMakeLists.txt
@@ -0,0 +1,47 @@
+include_directories(../../../Utility/)
+
+add_lldb_library(lldbPluginProcessUtility
+ DynamicRegisterInfo.cpp
+ FreeBSDSignals.cpp
+ GDBRemoteSignals.cpp
+ HistoryThread.cpp
+ HistoryUnwind.cpp
+ InferiorCallPOSIX.cpp
+ LinuxSignals.cpp
+ MipsLinuxSignals.cpp
+ NetBSDSignals.cpp
+ RegisterContextDarwin_arm.cpp
+ RegisterContextDarwin_arm64.cpp
+ RegisterContextDarwin_i386.cpp
+ RegisterContextDarwin_x86_64.cpp
+ RegisterContextDummy.cpp
+ RegisterContextFreeBSD_arm.cpp
+ RegisterContextFreeBSD_arm64.cpp
+ RegisterContextFreeBSD_i386.cpp
+ RegisterContextFreeBSD_mips64.cpp
+ RegisterContextFreeBSD_powerpc.cpp
+ RegisterContextFreeBSD_x86_64.cpp
+ RegisterContextHistory.cpp
+ RegisterContextLinux_arm.cpp
+ RegisterContextLinux_arm64.cpp
+ RegisterContextLinux_i386.cpp
+ RegisterContextLinux_x86_64.cpp
+ RegisterContextLinux_mips64.cpp
+ RegisterContextLinux_mips.cpp
+ RegisterContextLLDB.cpp
+ RegisterContextMacOSXFrameBackchain.cpp
+ RegisterContextMach_arm.cpp
+ RegisterContextMach_i386.cpp
+ RegisterContextMach_x86_64.cpp
+ RegisterContextMemory.cpp
+ RegisterContextPOSIX_arm.cpp
+ RegisterContextPOSIX_arm64.cpp
+ RegisterContextPOSIX_mips64.cpp
+ RegisterContextPOSIX_powerpc.cpp
+ RegisterContextPOSIX_x86.cpp
+ RegisterContextThreadMemory.cpp
+ StopInfoMachException.cpp
+ ThreadMemory.cpp
+ UnwindLLDB.cpp
+ UnwindMacOSXFrameBackchain.cpp
+ )