aboutsummaryrefslogtreecommitdiff
path: root/source/Plugins/SymbolFile/DWARF/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'source/Plugins/SymbolFile/DWARF/CMakeLists.txt')
-rw-r--r--source/Plugins/SymbolFile/DWARF/CMakeLists.txt18
1 files changed, 17 insertions, 1 deletions
diff --git a/source/Plugins/SymbolFile/DWARF/CMakeLists.txt b/source/Plugins/SymbolFile/DWARF/CMakeLists.txt
index 5ce20cc0989c..fb468440f9e0 100644
--- a/source/Plugins/SymbolFile/DWARF/CMakeLists.txt
+++ b/source/Plugins/SymbolFile/DWARF/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_lldb_library(lldbPluginSymbolFileDWARF
+add_lldb_library(lldbPluginSymbolFileDWARF PLUGIN
DIERef.cpp
DWARFAbbreviationDeclaration.cpp
DWARFASTParserClang.cpp
@@ -32,4 +32,20 @@ add_lldb_library(lldbPluginSymbolFileDWARF
SymbolFileDWARFDwo.cpp
SymbolFileDWARFDebugMap.cpp
UniqueDWARFASTType.cpp
+
+ LINK_LIBS
+ clangAST
+ clangBasic
+ lldbCore
+ lldbExpression
+ lldbHost
+ lldbInterpreter
+ lldbSymbol
+ lldbTarget
+ lldbUtility
+ lldbPluginObjCLanguage
+ lldbPluginCPlusPlusLanguage
+ lldbPluginExpressionParserClang
+ LINK_COMPONENTS
+ Support
)